summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-speech-framework/conf')
-rw-r--r--meta-speech-framework/conf/include/agl-speech-framework.inc2
-rw-r--r--meta-speech-framework/conf/include/agl-voiceagent-alexa.inc1
-rw-r--r--meta-speech-framework/conf/layer.conf15
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-speech-framework/conf/include/agl-speech-framework.inc b/meta-speech-framework/conf/include/agl-speech-framework.inc
new file mode 100644
index 00000000..9b7a0f07
--- /dev/null
+++ b/meta-speech-framework/conf/include/agl-speech-framework.inc
@@ -0,0 +1,2 @@
+# Currently no default voiceagent
+PREFERRED_RPROVIDER_virtual/voiceagent ?= ""
diff --git a/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
new file mode 100644
index 00000000..9da48212
--- /dev/null
+++ b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
@@ -0,0 +1 @@
+PREFERRED_RPROVIDER_virtual/voiceagent = "alexa-voiceagent-service"
diff --git a/meta-speech-framework/conf/layer.conf b/meta-speech-framework/conf/layer.conf
index 8ab7eb01..ce97b9e0 100644
--- a/meta-speech-framework/conf/layer.conf
+++ b/meta-speech-framework/conf/layer.conf
@@ -1,6 +1,21 @@
# We have a conf and classes directory, add to BBPATH
BBPATH .= ":${LAYERDIR}"
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration -
+# e.g. only add layers if a bsp is present.
+# This is based on the BBFILE_COLLECTIONS name of the layer.
+# We use either the BBFILE_COLLECTIONS name of the layer directly (meta-ti)
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# or we prepend it with meta- (e.g. rpi, fsl*)
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+
# We have recipes-* directories, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"