summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch')
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch286
1 files changed, 0 insertions, 286 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch
deleted file mode 100644
index 5886709b..00000000
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch
+++ /dev/null
@@ -1,286 +0,0 @@
-Add autobuild scripts
-
-Add autobuild scripts and update .gitignore to not ignore them.
-The autobuild/agl/autobuild script will be required for building widgets
-in AGL, add the latest version to the voiceagent source tree.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/.gitignore b/.gitignore
-index b3c1108..edbf1b5 100644
---- a/.gitignore
-+++ b/.gitignore
-@@ -1,3 +1,2 @@
--autobuild/
- build/
- alexa-voiceagent-apidef.h
-diff --git a/autobuild/agl/autobuild b/autobuild/agl/autobuild
-new file mode 100755
-index 0000000..16181b8
---- /dev/null
-+++ b/autobuild/agl/autobuild
-@@ -0,0 +1,128 @@
-+#!/usr/bin/make -f
-+# Copyright (C) 2015 - 2018 "IoT.bzh"
-+# Copyright (C) 2020 Konsulko Group
-+# Author "Romain Forlot" <romain.forlot@iot.bzh>
-+#
-+# Licensed under the Apache License, Version 2.0 (the "License");
-+# you may not use this file except in compliance with the License.
-+# You may obtain a copy of the License at
-+#
-+# http://www.apache.org/licenses/LICENSE-2.0
-+#
-+# Unless required by applicable law or agreed to in writing, software
-+# distributed under the License is distributed on an "AS IS" BASIS,
-+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+# See the License for the specific language governing permissions and
-+# limitations under the License.
-+
-+THISFILE := $(lastword $(MAKEFILE_LIST))
-+ROOT_DIR := $(abspath $(dir $(THISFILE))/../..)
-+
-+# Build directories
-+# Note that the debug/test/coverage directories are defined in relation
-+# to the release directory (BUILD_DIR), this needs to be kept in mind
-+# if over-riding it and building those widget types, the specific widget
-+# type variable (e.g. BUILD_DIR_DEBUG) may also need to be specified
-+# to yield the desired output hierarchy.
-+BUILD_DIR = $(ROOT_DIR)/build
-+BUILD_DIR_DEBUG = $(abspath $(BUILD_DIR)/../build-debug)
-+BUILD_DIR_TEST = $(abspath $(BUILD_DIR)/../build-test)
-+BUILD_DIR_COVERAGE = $(abspath $(BUILD_DIR)/../build-coverage)
-+
-+# Output directory variable for use in pattern rules.
-+# This is intended for internal use only, hence the explicit override
-+# definition.
-+override OUTPUT_DIR = $(BUILD_DIR)
-+
-+# Final install directory for widgets
-+DEST = $(OUTPUT_DIR)
-+
-+# Default build type for release/test builds
-+BUILD_TYPE = RELEASE
-+
-+.PHONY: all help update install distclean
-+.PHONY: clean clean-release clean-debug clean-test clean-coverage clean-all
-+.PHONY: configure configure-release configure-debug configure-test configure-coverage
-+.PHONY: build build-release build-debug build-test build-coverage build-all
-+.PHONY: package package-release package-debug package-test package-coverage package-all
-+
-+help:
-+ @echo "List of targets available:"
-+ @echo ""
-+ @echo "- all"
-+ @echo "- help"
-+ @echo "- clean"
-+ @echo "- distclean"
-+ @echo "- configure"
-+ @echo "- build: compilation, link and prepare files for package into a widget"
-+ @echo "- package: output a widget file '*.wgt'"
-+ @echo "- install: install in your $(CMAKE_INSTALL_DIR) directory"
-+ @echo ""
-+ @echo "Usage: ./autobuild/agl/autobuild package DEST=${HOME}/opt"
-+ @echo "Don't use your build dir as DEST as wgt file is generated at this location"
-+
-+all: package-all
-+
-+# Target specific variable over-rides so static pattern rules can be
-+# used for the various type-specific targets.
-+
-+configure-test build-test package-test clean-test: OUTPUT_DIR = $(BUILD_DIR_TEST)
-+
-+configure-coverage build-coverage package-coverage clean-coverage: OUTPUT_DIR = $(BUILD_DIR_COVERAGE)
-+configure-coverage build-coverage package-coverage: BUILD_TYPE = COVERAGE
-+
-+configure-debug build-debug package-debug clean-debug: OUTPUT_DIR = $(BUILD_DIR_DEBUG)
-+configure-debug build-debug package-debug: BUILD_TYPE = DEBUG
-+
-+clean-release clean-test clean-debug clean-coverage:
-+ @if [ -d $(OUTPUT_DIR) ]; then \
-+ $(MAKE) -C $(OUTPUT_DIR) $(CLEAN_ARGS) clean; \
-+ else \
-+ echo Nothing to clean; \
-+ fi
-+
-+clean: clean-release
-+
-+clean-all: clean-release clean-test clean-debug clean-coverage
-+
-+distclean: clean-all
-+
-+configure-release configure-test configure-debug configure-coverage:
-+ @mkdir -p $(OUTPUT_DIR)
-+ @if [ ! -f $(OUTPUT_DIR)/Makefile ]; then \
-+ (cd $(OUTPUT_DIR) && cmake -S $(ROOT_DIR) -DCMAKE_BUILD_TYPE=$(BUILD_TYPE) $(CONFIGURE_ARGS)); \
-+ fi
-+
-+configure: configure-release
-+
-+build-release build-debug build-coverage: build-%: configure-%
-+ @cmake --build $(OUTPUT_DIR) $(BUILD_ARGS) --target all
-+
-+# Kept for consistency, empty to avoid building everything for test widget
-+build-test: configure-test
-+
-+build: build-release
-+
-+build-all: build-release build-debug build-test build-coverage
-+
-+package-release package-debug package-coverage: package-%: build-%
-+ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target widget
-+ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
-+ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
-+ fi
-+
-+package-test: build-test
-+ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target test_widget
-+ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
-+ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
-+ fi
-+
-+package: package-release
-+
-+package-all: package-release package-test package-coverage package-debug
-+
-+update: configure
-+ @cmake --build $(BUILD_DIR) --target autobuild
-+
-+install: build
-+ @cmake --build $(BUILD_DIR) $(INSTALL_ARGS) --target install
-diff --git a/autobuild/linux/autobuild b/autobuild/linux/autobuild
-new file mode 100755
-index 0000000..16181b8
---- /dev/null
-+++ b/autobuild/linux/autobuild
-@@ -0,0 +1,128 @@
-+#!/usr/bin/make -f
-+# Copyright (C) 2015 - 2018 "IoT.bzh"
-+# Copyright (C) 2020 Konsulko Group
-+# Author "Romain Forlot" <romain.forlot@iot.bzh>
-+#
-+# Licensed under the Apache License, Version 2.0 (the "License");
-+# you may not use this file except in compliance with the License.
-+# You may obtain a copy of the License at
-+#
-+# http://www.apache.org/licenses/LICENSE-2.0
-+#
-+# Unless required by applicable law or agreed to in writing, software
-+# distributed under the License is distributed on an "AS IS" BASIS,
-+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+# See the License for the specific language governing permissions and
-+# limitations under the License.
-+
-+THISFILE := $(lastword $(MAKEFILE_LIST))
-+ROOT_DIR := $(abspath $(dir $(THISFILE))/../..)
-+
-+# Build directories
-+# Note that the debug/test/coverage directories are defined in relation
-+# to the release directory (BUILD_DIR), this needs to be kept in mind
-+# if over-riding it and building those widget types, the specific widget
-+# type variable (e.g. BUILD_DIR_DEBUG) may also need to be specified
-+# to yield the desired output hierarchy.
-+BUILD_DIR = $(ROOT_DIR)/build
-+BUILD_DIR_DEBUG = $(abspath $(BUILD_DIR)/../build-debug)
-+BUILD_DIR_TEST = $(abspath $(BUILD_DIR)/../build-test)
-+BUILD_DIR_COVERAGE = $(abspath $(BUILD_DIR)/../build-coverage)
-+
-+# Output directory variable for use in pattern rules.
-+# This is intended for internal use only, hence the explicit override
-+# definition.
-+override OUTPUT_DIR = $(BUILD_DIR)
-+
-+# Final install directory for widgets
-+DEST = $(OUTPUT_DIR)
-+
-+# Default build type for release/test builds
-+BUILD_TYPE = RELEASE
-+
-+.PHONY: all help update install distclean
-+.PHONY: clean clean-release clean-debug clean-test clean-coverage clean-all
-+.PHONY: configure configure-release configure-debug configure-test configure-coverage
-+.PHONY: build build-release build-debug build-test build-coverage build-all
-+.PHONY: package package-release package-debug package-test package-coverage package-all
-+
-+help:
-+ @echo "List of targets available:"
-+ @echo ""
-+ @echo "- all"
-+ @echo "- help"
-+ @echo "- clean"
-+ @echo "- distclean"
-+ @echo "- configure"
-+ @echo "- build: compilation, link and prepare files for package into a widget"
-+ @echo "- package: output a widget file '*.wgt'"
-+ @echo "- install: install in your $(CMAKE_INSTALL_DIR) directory"
-+ @echo ""
-+ @echo "Usage: ./autobuild/agl/autobuild package DEST=${HOME}/opt"
-+ @echo "Don't use your build dir as DEST as wgt file is generated at this location"
-+
-+all: package-all
-+
-+# Target specific variable over-rides so static pattern rules can be
-+# used for the various type-specific targets.
-+
-+configure-test build-test package-test clean-test: OUTPUT_DIR = $(BUILD_DIR_TEST)
-+
-+configure-coverage build-coverage package-coverage clean-coverage: OUTPUT_DIR = $(BUILD_DIR_COVERAGE)
-+configure-coverage build-coverage package-coverage: BUILD_TYPE = COVERAGE
-+
-+configure-debug build-debug package-debug clean-debug: OUTPUT_DIR = $(BUILD_DIR_DEBUG)
-+configure-debug build-debug package-debug: BUILD_TYPE = DEBUG
-+
-+clean-release clean-test clean-debug clean-coverage:
-+ @if [ -d $(OUTPUT_DIR) ]; then \
-+ $(MAKE) -C $(OUTPUT_DIR) $(CLEAN_ARGS) clean; \
-+ else \
-+ echo Nothing to clean; \
-+ fi
-+
-+clean: clean-release
-+
-+clean-all: clean-release clean-test clean-debug clean-coverage
-+
-+distclean: clean-all
-+
-+configure-release configure-test configure-debug configure-coverage:
-+ @mkdir -p $(OUTPUT_DIR)
-+ @if [ ! -f $(OUTPUT_DIR)/Makefile ]; then \
-+ (cd $(OUTPUT_DIR) && cmake -S $(ROOT_DIR) -DCMAKE_BUILD_TYPE=$(BUILD_TYPE) $(CONFIGURE_ARGS)); \
-+ fi
-+
-+configure: configure-release
-+
-+build-release build-debug build-coverage: build-%: configure-%
-+ @cmake --build $(OUTPUT_DIR) $(BUILD_ARGS) --target all
-+
-+# Kept for consistency, empty to avoid building everything for test widget
-+build-test: configure-test
-+
-+build: build-release
-+
-+build-all: build-release build-debug build-test build-coverage
-+
-+package-release package-debug package-coverage: package-%: build-%
-+ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target widget
-+ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
-+ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
-+ fi
-+
-+package-test: build-test
-+ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target test_widget
-+ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
-+ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
-+ fi
-+
-+package: package-release
-+
-+package-all: package-release package-test package-coverage package-debug
-+
-+update: configure
-+ @cmake --build $(BUILD_DIR) --target autobuild
-+
-+install: build
-+ @cmake --build $(BUILD_DIR) $(INSTALL_ARGS) --target install