summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/meta-agl-uhmi-demo/recipes-config
diff options
context:
space:
mode:
Diffstat (limited to 'meta-uhmi/meta-agl-uhmi-demo/recipes-config')
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/app.json49
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/initial_vscreen.json20
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/uhmi-ivi-wm.conf3
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-receiver.config7
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-sender.config7
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/set-hostname.inc5
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-receiver.bb22
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb29
8 files changed, 142 insertions, 0 deletions
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/app.json b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/app.json
new file mode 100644
index 00000000..1dcce8aa
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/app.json
@@ -0,0 +1,49 @@
+{
+ "format_v1": {
+ "command_type" : "remote_virtio_gpu",
+ "appli_name" : "glmark2",
+ "sender" : {
+ "launcher" : "agl-host0",
+ "command" : "/usr/bin/ucl-virtio-gpu-wl-send",
+ "frontend_params" : {
+ "scanout_x" : 0,
+ "scanout_y" : 0,
+ "scanout_w" : 1920,
+ "scanout_h" : 1080,
+ "server_port" : 33445
+ },
+ "appli" : "/usr/bin/glmark2-es2-wayland -s 1920x1080",
+ "env" : "LD_LIBRARY_PATH=/usr/lib/mesa-virtio"
+ },
+ "receivers" : [
+ {
+ "launcher" : "agl-host0",
+ "command" : "/usr/bin/ucl-virtio-gpu-wl-recv",
+ "backend_params" : {
+ "ivi_surface_id" : 101000,
+ "scanout_x" : 0,
+ "scanout_y" : 0,
+ "scanout_w" : 1920,
+ "scanout_h" : 1080,
+ "listen_port" : 33445,
+ "initial_screen_color" : "0x33333333"
+ },
+ "env" : "XDG_RUNTIME_DIR=/run/user/200 WAYLAND_DISPLAY=wayland-1"
+ },
+ {
+ "launcher" : "agl-host1",
+ "command" : "/usr/bin/ucl-virtio-gpu-wl-recv",
+ "backend_params" : {
+ "ivi_surface_id" : 101000,
+ "scanout_x" : 0,
+ "scanout_y" : 0,
+ "scanout_w" : 1920,
+ "scanout_h" : 1080,
+ "listen_port" : 33445,
+ "initial_screen_color" : "0x33333333"
+ },
+ "env" : "XDG_RUNTIME_DIR=/run/user/200 WAYLAND_DISPLAY=wayland-1"
+ }
+ ]
+ }
+}
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/initial_vscreen.json b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/initial_vscreen.json
new file mode 100644
index 00000000..d6ac7771
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/initial_vscreen.json
@@ -0,0 +1,20 @@
+{
+ "command": "initial_vscreen",
+ "vlayer": [
+ {
+ "VID": 1010000,
+ "coord": "global",
+ "virtual_w": 1920, "virtual_h": 1080,
+ "vsrc_x": 0, "vsrc_y": 0, "vsrc_w": 1920, "vsrc_h": 1080,
+ "vdst_x": 960, "vdst_y": 0, "vdst_w": 1920, "vdst_h": 1080,
+ "vsurface": [
+ {
+ "VID": 101000,
+ "pixel_w": 1920, "pixel_h": 1080,
+ "psrc_x": 0, "psrc_y": 0, "psrc_w": 1920, "psrc_h": 1080,
+ "vdst_x": 0, "vdst_y": 0, "vdst_w": 1920, "vdst_h": 1080
+ }
+ ]
+ }
+ ]
+}
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/uhmi-ivi-wm.conf b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/uhmi-ivi-wm.conf
new file mode 100644
index 00000000..546a61c4
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/uhmi-ivi-wm.conf
@@ -0,0 +1,3 @@
+[Service]
+Environment="XDG_RUNTIME_DIR=/run/user/200"
+Environment="WAYLAND_DISPLAY=wayland-1"
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-receiver.config b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-receiver.config
new file mode 100644
index 00000000..9d6b3a63
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-receiver.config
@@ -0,0 +1,7 @@
+[global]
+Name = Wired
+Description = Wired network configuration
+
+[service_ether]
+Type = ethernet
+IPv4 = 192.168.0.101/24
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-sender.config b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-sender.config
new file mode 100644
index 00000000..777a3e95
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/files/wired-sender.config
@@ -0,0 +1,7 @@
+[global]
+Name = Wired
+Description = Wired network configuration
+
+[service_ether]
+Type = ethernet
+IPv4 = 192.168.0.100/24
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/set-hostname.inc b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/set-hostname.inc
new file mode 100644
index 00000000..9ff5339e
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/set-hostname.inc
@@ -0,0 +1,5 @@
+set_hostname() {
+ UHMI_HOSTNAME=${UHMI_HOSTNAME:-agl-host}
+ echo "${UHMI_HOSTNAME}" > ${IMAGE_ROOTFS}/${sysconfdir}/hostname
+}
+ROOTFS_POSTPROCESS_COMMAND:append = " set_hostname;"
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-receiver.bb b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-receiver.bb
new file mode 100644
index 00000000..94092b13
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-receiver.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Setting files for UHMI receiver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = " \
+ file://wired-receiver.config \
+ file://uhmi-ivi-wm.conf \
+"
+
+do_install() {
+ if [ ! -e ${D}/var/lib/connman/wired.config ]; then
+ install -d ${D}/var/lib/connman/
+ install -m 6444 ${WORKDIR}/wired-receiver.config ${D}/var/lib/connman/wired.config
+ fi
+
+ install -d ${D}/etc/systemd/system/uhmi-ivi-wm.service.d/
+ install -m 0644 ${WORKDIR}/uhmi-ivi-wm.conf ${D}/etc/systemd/system/uhmi-ivi-wm.service.d/
+}
+
+FILES:${PN} += " \
+ /var/lib/connman/wired.config \
+"
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb
new file mode 100644
index 00000000..ee854d85
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Setting files for UHMI sender"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = " \
+ file://app.json \
+ file://initial_vscreen.json \
+ file://wired-sender.config \
+ file://uhmi-ivi-wm.conf \
+"
+
+do_install() {
+ if [ ! -e ${D}/var/lib/connman/wired.config ]; then
+ install -d ${D}/var/lib/connman/
+ install -m 6444 ${WORKDIR}/wired-sender.config ${D}/var/lib/connman/wired.config
+ fi
+
+ install -d ${D}/var/local/uhmi-app/glmark2
+ install -m 644 ${WORKDIR}/app.json ${D}/var/local/uhmi-app/glmark2/
+ install -m 644 ${WORKDIR}/initial_vscreen.json ${D}/var/local/uhmi-app/glmark2/
+
+ install -d ${D}/etc/systemd/system/uhmi-ivi-wm.service.d/
+ install -m 0644 ${WORKDIR}/uhmi-ivi-wm.conf ${D}/etc/systemd/system/uhmi-ivi-wm.service.d/
+}
+
+FILES:${PN} += " \
+ /var/lib/connman/wired.config \
+ /var/local/uhmi-app/glmark2 \
+"