summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/meta-rvgpu
diff options
context:
space:
mode:
Diffstat (limited to 'meta-uhmi/meta-rvgpu')
-rw-r--r--meta-uhmi/meta-rvgpu/README.md54
-rw-r--r--meta-uhmi/meta-rvgpu/conf/layer.conf17
-rw-r--r--meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg6
-rw-r--r--meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend9
-rw-r--r--meta-uhmi/meta-rvgpu/dynamic-layers/rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend1
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb59
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc6
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb22
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb19
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/uinput.cfg2
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/virtio-gpu.cfg1
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-rvgpu.inc8
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-yocto_%.bbappend1
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver.inc6
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb28
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb11
16 files changed, 0 insertions, 250 deletions
diff --git a/meta-uhmi/meta-rvgpu/README.md b/meta-uhmi/meta-rvgpu/README.md
deleted file mode 100644
index 3d524fef..00000000
--- a/meta-uhmi/meta-rvgpu/README.md
+++ /dev/null
@@ -1,54 +0,0 @@
-## How to run RVGPU remotely
-Prepare two images, one as the Sender and the other as the Receiver.
-It is necessary for the Sender and Receiver to be within the same network.
-
-**Receiver side**
-```
-$ export XDG_RUNTIME_DIR=/run/user/<your_UID>
-$ rvgpu-renderer -b <your_Area>@0,0 -p <Port_Number> &
-```
-
-Replace the placeholders with the appropriate values:
-- `<your_UID>`: Specify according to your environment, for example: 200
-- `<your_Area>`: Enter an usable area for example: 1920x1080
-- `<Port_Number>`: Enter an available port number, for example: 55555
-
-**Sender side**
-Create the following shell script **run_remote_app.sh** in any `<WORKDIR>` for a smooth experience.
-```
-#!/bin/bash
-
-export XDG_RUNTIME_DIR=/tmp
-export LD_LIBRARY_PATH=/usr/lib/mesa-virtio
-
-# -------------
-# launch app
-# -------------
-$@
-```
-
-Save the file and run the following to start weston.
-
-```
-$ rvgpu-proxy -s <your_Area>@0,0 -n <IP_address_of_Receiver>:<Port_Number> &
-$ EGLWINSYS_DRM_DEV_NAME=<RVGPU_DRM_DEVICE_PATH> <WORKDIR>/run_remote_app.sh rvgpu-wlproxy -s <your_Area> -S <your_WAYLAND_DISPLAY> &
-```
-Replace the placeholders with the appropriate values:
-- `<Port_Number>`: Port set in the renderer.
-- `<your_WAYLAND_DISPLAY>`: Specify your WAYLAND_DISPLAY socket name, for example: wayland-uhmi-0
-- `<RVGPU_DRM_DEVICE_PATH>`: Specify rvgpu drm device path generated by rvgpu-proxy, for example: /dev/dri/rvgpu_virtio0
-
-After completing these steps, the Weston screen from the Sender will be transferred and displayed on the Receiver using rvgpu-proxy and rvgpu-renderer. You can verify that everything is functioning properly by launching wayland applications on the Sender side, such as:
-```
-$ WAYLAND_DISPLAY=<your_WAYLAND_DISPLAY> <WORKDIR>/run_remote_app.sh weston-simple-egl -f
-```
-
-You can also verify the touch or keyboard operation support of the RVGPU by using app such as
-```
-$ WAYLAND_DISPLAY=<your_WAYLAND_DISPLAY> <WORKDIR>/run_remote_app.sh weston-smoke
-$ WAYLAND_DISPLAY=<your_WAYLAND_DISPLAY> <WORKDIR>/run_remote_app.sh weston-editor
-```
-
-**Appendix**
-- By building the RVGPU on Ubuntu, it is possible to enable bidirectional remote rendering between the agl-demo-platform and Ubuntu.
-For the build procedure on Ubuntu, see the following URL: https://github.com/unified-hmi/remote-virtio-gpu \ No newline at end of file
diff --git a/meta-uhmi/meta-rvgpu/conf/layer.conf b/meta-uhmi/meta-rvgpu/conf/layer.conf
deleted file mode 100644
index 5451560f..00000000
--- a/meta-uhmi/meta-rvgpu/conf/layer.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "meta-rvgpu"
-BBFILE_PATTERN_meta-rvgpu = "^${LAYERDIR}/"
-BBFILE_PRIORITY_meta-rvgpu = "8"
-
-BBFILES_DYNAMIC += " \
- rcar-gen3:${LAYERDIR}/dynamic-layers/rcar-gen3/*/*/*.bbappend \
- raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bbappend \
-"
-
-LAYERSERIES_COMPAT_meta-rvgpu= "scarthgap"
diff --git a/meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg b/meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg
deleted file mode 100644
index 82ff9ea1..00000000
--- a/meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg
+++ /dev/null
@@ -1,6 +0,0 @@
-CONFIG_VIRTIO=y
-CONFIG_VIRTIO_MMIO=y
-CONFIG_VIRTIO_BLK=y
-CONFIG_VIRTIO_BLK_SCSI=y
-CONFIG_VIRTIO_PCI=y
-CONFIG_VIRTIO_PCI_LEGACY=y
diff --git a/meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
deleted file mode 100644
index d093e40f..00000000
--- a/meta-uhmi/meta-rvgpu/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
-require recipes-kernel/linux/linux-rvgpu.inc
-
-FILESEXTRAPATHS:prepend := "${THISDIR}/linux-common/:"
-
-SRC_URI:append = " \
- file://enable-virtio.cfg \
-"
-
-KERNEL_MODULE_AUTOLOAD:append = " virtio-gpu"
diff --git a/meta-uhmi/meta-rvgpu/dynamic-layers/rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-uhmi/meta-rvgpu/dynamic-layers/rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
deleted file mode 100644
index 1b238eea..00000000
--- a/meta-uhmi/meta-rvgpu/dynamic-layers/rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require recipes-kernel/linux/linux-rvgpu.inc
diff --git a/meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb b/meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
deleted file mode 100644
index 9a0dab2f..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
+++ /dev/null
@@ -1,59 +0,0 @@
-SUMMARY = "Mesa library"
-SECTION = "graphics"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://docs/license.rst;md5=9aa1bc48c9826ad9fdb16661f6930496"
-
-
-DEPENDS = "expat makedepend-native flex-native bison-native libxml2-native zlib chrpath-replacement-native python3-mako-native gettext-native"
-DEPENDS:append = " libdrm wayland wayland-native wayland-protocols python3-native"
-
-SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz"
-
-SRC_URI[md5] = "224d7576618ef4dd8ac69f30b5b90b38"
-SRC_URI[sha256sum] = "909a72df63dfa3c0844ccf44a26ac028d148297ed333ab51560893923d7691ce"
-
-S = "${WORKDIR}/mesa-${PV}"
-
-RDEPENDS:${PN}:append = " libgcc wayland libdrm glibc libstdc++ zlib expat"
-
-inherit meson pkgconfig python3native gettext
-
-EXTRA_OEMESON = " \
- -Dshared-glapi=true \
- -Dgallium-opencl=disabled \
- -Dglx-read-only-text=true \
- -Dplatforms='wayland' \
-"
-
-EXTRA_OEMESON += " \
- --prefix=/usr/lib/mesa-virtio \
- --libdir=/usr/lib/mesa-virtio \
- --sysconfdir=/etc/mesa-virtio \
-"
-
-EXTRA_OEMESON += " \
- -Ddri-drivers='' \
- -Dgallium-drivers='virgl,swrast' \
- -Dglx=disabled \
- -Dgles1=disabled \
- -Dgles2=enabled \
- -Degl=true \
- -Dgbm=true \
- -Dllvm=disabled \
- -Dvulkan-drivers='[]' \
-"
-
-FILES:${PN} = " \
- /usr/lib/mesa-virtio/* \
- /etc/mesa-virtio/drirc \
- /usr/share/mesa-virtio/* \
-"
-
-FILES:${PN}-dev += " \
- /usr/lib/mesa-virtio/libglapi.so \
- /usr/lib/mesa-virtio/libEGL.so \
- /usr/lib/mesa-virtio/libgbm.so \
- /usr/lib/mesa-virtio/libGLESv2.so \
- /usr/lib/mesa-virtio/libGLESv1_CM.so \
-"
diff --git a/meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc b/meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc
deleted file mode 100644
index ddd6dbab..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-PV = "0.0+git${SRCPV}"
-SRCREV = "bce1f77f189dacf3e57d2f4edc37be4ff63b9e4b"
-BRANCH ?= "main"
-SRC_URI = " \
- git://github.com/unified-hmi/remote-virtio-gpu.git;protocol=https;branch=${BRANCH} \
-"
diff --git a/meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb b/meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb
deleted file mode 100644
index 86e456c3..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Remote virtual display userland"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=573c152503e0d9b97c8e0cc09fbb1ad2"
-
-require remote-virtio-gpu.inc
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "virglrenderer virtual/libgbm wayland wayland-native libepoxy libinput virtio-loopback-driver"
-RDEPENDS:${PN} = " wayland libgles2"
-
-inherit cmake pkgconfig
-
-PACKAGECONFIG_CONFARGS += " \
- -DCMAKE_BUILD_TYPE=Release \
-"
-
-FILES:SOLIBSDEV = ""
-FILES:${PN} += " \
- ${libdir}/librvgpu.so* \
-"
diff --git a/meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb b/meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb
deleted file mode 100644
index 5f6a70f2..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Panasonic UHMI RVGPU Wayland Proxy"
-DEPENDS = " virtual/libgbm libinput libxkbcommon"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a8a0cf4075753e7d7e8c948171357af0"
-
-SRCREV ="067d46a8977852afb8b503bd7d833b9037673db4"
-BRANCH ?= "main"
-
-SRC_URI = " \
- git://github.com/unified-hmi/rvgpu-wlproxy.git;protocol=https;branch=${BRANCH} \
-"
-PV = "0.0+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-inherit pkgconfig cmake
-
-FILES:${PN} += "/usr/bin/*"
diff --git a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/uinput.cfg b/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/uinput.cfg
deleted file mode 100644
index fd1f78ea..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/uinput.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_INPUT_UINPUT=y
-CONFIG_INPUT_MISC=y
diff --git a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/virtio-gpu.cfg b/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/virtio-gpu.cfg
deleted file mode 100644
index 5db61502..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-common/virtio-gpu.cfg
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_DRM_VIRTIO_GPU=y
diff --git a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-rvgpu.inc b/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-rvgpu.inc
deleted file mode 100644
index 5d405afd..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-rvgpu.inc
+++ /dev/null
@@ -1,8 +0,0 @@
-DESCRIPTION = "Enable linux virtio-loopback driver"
-
-FILESEXTRAPATHS:prepend := "${THISDIR}/linux-common/:"
-
-SRC_URI:append = " \
- file://virtio-gpu.cfg \
- file://uinput.cfg \
-"
diff --git a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-yocto_%.bbappend
deleted file mode 100644
index 9dd82e3c..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-kernel/linux/linux-yocto_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require linux-rvgpu.inc
diff --git a/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver.inc b/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver.inc
deleted file mode 100644
index a7c0111b..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-PV = "0.0+git${SRCPV}"
-SRCREV = "cf40e4d295c75567cb7d1d03f9fe291e9593e882"
-BRANCH ?= "main"
-SRC_URI = " \
- git://github.com/unified-hmi/virtio-loopback-driver.git;protocol=https;branch=${BRANCH} \
-"
diff --git a/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb b/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb
deleted file mode 100644
index b9682aee..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "Remote virtual display device driver"
-
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=688693ebbe31e3eadf819d7d007fa654"
-
-require virtio-loopback-driver.inc
-
-S = "${WORKDIR}/git"
-
-inherit module
-
-EXTRA_OEMAKE = "M=${S} -C ${STAGING_KERNEL_DIR}"
-
-do_install:append() {
- install -d ${D}${PKG_CONFIG_SYSTEM_INCLUDE_PATH}/linux
- install -m 755 ${S}/virtio_lo.h ${D}${PKG_CONFIG_SYSTEM_INCLUDE_PATH}/linux/
- # Add this section to install virtio_lo.conf
- install -d ${D}${sysconfdir}/modules-load.d
- echo "virtio_lo" > ${D}${sysconfdir}/modules-load.d/virtio_lo.conf
-}
-
-FILES:${PN} = " \
- ${libdir}/modules/${KERNEL_VERSION}/extra/virtio_lo* \
- ${sysconfdir}/modules-load.d \
-"
-
-# Autoload virtio lo driver
-KERNEL_MODULE_AUTOLOAD:append = " virtio_lo"
diff --git a/meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb b/meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb
deleted file mode 100644
index d7f55043..00000000
--- a/meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-SUMMARY = "Unified HMI Package Groups"
-LICENSE = "Apache-2.0"
-
-inherit packagegroup
-
-RDEPENDS:${PN} += " \
- remote-virtio-gpu \
- virtio-loopback-driver \
- mesa-virtio \
- rvgpu-wlproxy \
-"