summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/recipes-graphics/wayland
diff options
context:
space:
mode:
Diffstat (limited to 'meta-uhmi/recipes-graphics/wayland')
-rw-r--r--meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch62
-rw-r--r--meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb26
2 files changed, 88 insertions, 0 deletions
diff --git a/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch
new file mode 100644
index 00000000..008d0f4b
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch
@@ -0,0 +1,62 @@
+From e7984b2a8a7508cdbc3f269f4e0789edcfe8b30a Mon Sep 17 00:00:00 2001
+From: James Thomas <james.thomas@codethink.co.uk>
+Date: Thu, 22 Feb 2024 12:26:58 +0000
+Subject: [PATCH] Update libweston to version 13
+
+Upstream-Status: Submitted [https://github.com/COVESA/wayland-ivi-extension/pull/185]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+---
+ CMakeLists.txt | 2 +-
+ weston-ivi-shell/src/ivi-controller.c | 10 +++++-----
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d6428c2..5917875 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ include(GNUInstallDirs)
+ SET(IVI_EXTENSION_VERSION 2.3.2)
+ SET(ILM_API_VERSION 2.3.2)
+
+-SET(LIBWESTON_VER 12)
++SET(LIBWESTON_VER 13)
+
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+ SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+diff --git a/weston-ivi-shell/src/ivi-controller.c b/weston-ivi-shell/src/ivi-controller.c
+index 4701aec..94ca83e 100644
+--- a/weston-ivi-shell/src/ivi-controller.c
++++ b/weston-ivi-shell/src/ivi-controller.c
+@@ -881,15 +881,15 @@ set_bkgnd_surface_prop(struct ivishell *shell)
+ wl_list_for_each(output, &compositor->output_list, link) {
+ if (!count)
+ {
+- x = output->x;
+- y = output->y;
++ x = output->pos.c.x;
++ y = output->pos.c.y;
+ count++;
+ }
+- dest_width = output->x + output->width;
++ dest_width = output->pos.c.x + output->width;
+ if (output->height > dest_height)
+ dest_height = output->height;
+ weston_log("set_bkgnd_surface_prop: o_name:%s x:%d y:%d o_width:%d o_height:%d\n",
+- output->name, output->x, output->y, output->width, output->height);
++ output->name, output->pos.c.x, output->pos.c.y, output->width, output->height);
+ }
+
+ w_surface = view->surface;
+@@ -2197,7 +2197,7 @@ launch_client_process(void *data)
+ setenv(IVI_CLIENT_ENABLE_CURSOR_ENV_NAME, option, 0x1);
+ }
+
+- shell->client = weston_client_start(shell->compositor,
++ shell->client = wet_client_start(shell->compositor,
+ shell->ivi_client_name);
+
+ shell->client_destroy_listener.notify = ivi_shell_client_destroy;
+--
+2.44.0
+
diff --git a/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
new file mode 100644
index 00000000..f7b25917
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "https://github.com/COVESA/wayland-ivi-extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
+
+DEPENDS = "weston virtual/libgles2 pixman wayland-native"
+
+PV = "2.3.2+git${SRCPV}"
+
+SRC_URI = " \
+ git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \
+ file://0001-Update-libweston-to-version-13.patch \
+"
+SRCREV = "60d616ad3abd925956207b9b6ff981afa004e792"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
+EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
+
+FILES:${PN} += "${datadir}/wayland-protocols/stable/ivi-application/ivi-application.xml"
+FILES:${PN} += "${libdir}/weston/*"
+FILES:${PN}-dbg += "${libdir}/weston/.debug/*"