summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-07-10 17:53:06 +0000
committerStephane DESNEUX <stephane.desneux@iot.bzh>2016-07-12 13:31:25 +0000
commit32633f7ceaaa866cbe5bc9260966efaf75c17959 (patch)
tree38fe787eec04f16049749ad434b0d8a3df2e5ba1
parentc664012d6a990813dcd4f7524c03e459c56eddf5 (diff)
meta-app-framework: af-binder must create ${libdir}/afb at postinst time
${libdir}/afb is the directory where bindings should be installed. If no binding is installed, the directory must still exist to avoid a startup error in afb-daemon. Change-Id: I8d2c85d67eec3c697c6abb072955d5e2de8c5e5f Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 4ab96bd..99ea243 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -23,6 +23,10 @@ inherit cmake pkgconfig
FILES_${PN} += "${datadir}"
+pkg_postinst_${PN}() {
+ mkdir -p "$D${libdir}/afb"
+}
+
#############################################
# setup meta package
#############################################