summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-06-24 11:01:25 +0200
committerStephane Desneux <stephane.desneux@iot.bzh>2016-06-28 21:54:24 +0000
commite80d00cccc8e35be720af43207e61990cbb8eab9 (patch)
treeebbd40fb214faeac2a8ebcc575283a52cfd00d8e
parent7cd29bd3a27f9402fc13093cb7294f6a9e1b0059 (diff)
upgrade to new namings and bug fixes
Change-Id: If7481696d130859e87f3110af2d0c5dde25615d6 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb18
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb10
-rw-r--r--meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb4
-rw-r--r--meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb2
4 files changed, 17 insertions, 17 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 4fcff66..3e4a8c6 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -1,6 +1,6 @@
SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented plugins (sound, radio...), \
+interface to various automotive-oriented bindings (sound, radio...), \
allowing HTML5 UIs to send platform-specific requests in a secure way."
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
@@ -16,7 +16,7 @@ SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
"
-SRCREV = "897aa6a130eab1eb716fcc13e650fb5833a7ce32"
+SRCREV = "7059e59cddc1c81321639875636e88895bc14309"
S = "${WORKDIR}/git"
inherit cmake pkgconfig
@@ -30,21 +30,21 @@ PACKAGES += "${PN}-meta"
ALLOW_EMPTY_${PN}-meta = "1"
#############################################
-# setup sample plugin packages
+# setup sample binding packages
#############################################
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
+PACKAGES_DYNAMIC = "${PN}-binding-*"
python populate_packages_prepend () {
afb_libdir = d.expand('${libdir}/afb')
- postinst = d.getVar('plugin_postinst', True)
+ postinst = d.getVar('binding_postinst', True)
pkgs = []
pkgs_dbg = []
- pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
- pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
+ pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
+ pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
- pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*)-api\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
- pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
+ pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*)-api\.so$', d.expand('${PN}-binding-%s-dbg'), 'AFB binding for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
+ pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s-dbg'), 'AFB binding for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
metapkg = d.getVar('PN', True) + '-meta'
d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index a29b071..dc030e2 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -22,7 +22,7 @@ SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
"
-SRCREV = "d0fdae3af6998efdce4c6ba0c5d650898c9c5b27"
+SRCREV = "8753c48ed498805cec5fbc6096cd6fae3afa0da9"
SECTION = "base"
@@ -33,7 +33,7 @@ DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c security-manager libcap
afm_name = "afm"
afm_confdir = "${sysconfdir}/${afm_name}"
afm_datadir = "${datadir}/${afm_name}"
-afb_plugin_dir = "${libdir}/afb"
+afb_binding_dir = "${libdir}/afb"
EXTRA_OECMAKE = "\
-DUSE_LIBZIP=1 \
@@ -83,9 +83,9 @@ pkg_postinst_${PN}_smack() {
setcap cap_mac_override,cap_mac_admin,cap_setgid=ie $D${bindir}/afm-user-daemon
}
-PACKAGES =+ "${PN}-afbplugin ${PN}-afbplugin-dbg"
-FILES_${PN}-afbplugin = " ${afb_plugin_dir}/afm-main-plugin.so "
-FILES_${PN}-afbplugin-dbg = " ${afb_plugin_dir}/.debug/afm-main-plugin.so "
+PACKAGES =+ "${PN}-binding ${PN}-binding-dbg"
+FILES_${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
+FILES_${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
FILES_${PN}-tools = "${bindir}/wgtpkg-*"
diff --git a/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb b/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
index 54a8216..6201cf4 100644
--- a/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
+++ b/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
@@ -1,13 +1,13 @@
SUMMARY = "HTML5 demo template for AFB"
DESCRIPTION = "afb-client is a sample AngularJS/HTML5 application using \
-Application Framework Binder with token plugin."
+Application Framework Binder with token binding."
HOMEPAGE = "http://www.iot.bzh"
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
#DEPENDS = "nodejs-native"
-RDEPENDS_${PN} = "af-binder af-binder-plugin-authlogin"
+RDEPENDS_${PN} = "af-binder af-binder-binding-authlogin"
SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=1.0"
SRC_URI_files = "file://afb-client \
diff --git a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb b/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
index b624b6b..78f525a 100644
--- a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
+++ b/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
@@ -10,7 +10,7 @@ LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
#DEPENDS = "nodejs-native"
-RDEPENDS_${PN} = "af-main af-binder af-main-afbplugin af-binder-plugin-demopost af-binder-plugin-authlogin"
+RDEPENDS_${PN} = "af-main af-binder af-main-binding af-binder-binding-demopost af-binder-binding-authlogin"
SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=1.0"
SRC_URI_files = "file://afm-client \