summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-07-18 15:48:59 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-07-18 16:29:30 +0000
commite89f9e5da0f507c30fff985b86f0b4e8c957c7ae (patch)
tree3c3fe3258f19075acfe5fb6ff37695af0abc26c5
parentcc06610fc964769651b7888c0dde7645779f3990 (diff)
meta-app-framework: install missing libafbwsc library
libafbwsc is a C WebSockets helper library needed for most native apffw clients, such as the default provided one, "afb-client-demo". Cherry-pick'ed to blowfish (jsmoeller@linuxfoundation.org) Change-Id: I321f62cbd6a04bc3e4b91e4de544865c83397979 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
index 79c6020..231d9c9 100644
--- a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
+++ b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
@@ -12,8 +12,9 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
af-binder \
- af-main \
- web-runtime \
af-binder-binding-afb-dbus-binding \
af-binder-binding-authlogin \
+ libafbwsc \
+ af-main \
+ web-runtime \
"
class="cm"> * Copyright (C) 2019 Konsulko Group * * Licensed under the Apache License, Version 2.0 (the "License"); * you may not use this file except in compliance with the License. * You may obtain a copy of the License at * * http://www.apache.org/licenses/LICENSE-2.0 * * Unless required by applicable law or agreed to in writing, software * distributed under the License is distributed on an "AS IS" BASIS, * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. * See the License for the specific language governing permissions and * limitations under the License. */ #ifndef MAP_MESSAGE_H #define MAP_MESSAGE_H #include "message.h" class MapMessage : public Message { Q_OBJECT public: bool createRequest(QString verb, QJsonObject parameter); bool isNotificationEvent() {return (this->eventName() == "notification"); }; private: QStringList verbs { "compose", "message", "list_messages", "subscribe", "unsubscribe", }; }; #endif // MAP_MESSAGE_H