summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-11-10 12:46:59 +0100
committerStephane Desneux <stephane.desneux@iot.bzh>2016-11-10 12:46:59 +0100
commit1d8243bda00e7628a6c24d0df5934c4627af2384 (patch)
treefe13f27bdc9d98eede3298dba04885b3f239cd39
parent47b5ad2d26c683ad9c5243e422e0a1bbdec4aff9 (diff)
meta-app-framework: fix unpackaged files in nativesdk-af-main
Recent changes in af-main now generate .pc (pkgconfig) files. These files shouldn't be packaged for nativesdk-af-main: they are just removed at the end of the install task to avoid the 'unpackaged files' error. Change-Id: I61364c430c0272e8e8a398e1e5640c856c668c1b Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
index 426e999..0169e6b 100644
--- a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
@@ -19,6 +19,11 @@ EXTRA_OECMAKE = "\
-Dafm_datadir=${afm_datadir} \
"
+do_install_append() {
+ # remove unused .pc file we don't want to package
+ rm -rf ${D}/${libdir}
+}
+
PACKAGES = "${PN}-tools ${PN}-tools-dbg"
FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"