summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-11-08 12:02:29 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2016-11-08 13:41:30 +0100
commit3b8a56651fe1598c0c2e50a8c079f111ebb824fe (patch)
treed8cda26b3fa552094255fdcf9b386279ad518b22
parenta70d7107e8f0dad2104f6b8eb295c722ce02309b (diff)
Added SOTA_VERSION that is displayed when user runs 'sota-client -v' on
the target machine Change-Id: Ifa04f2fb5f6cd5e0ecd2a14af07128e030a44a8b Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
-rw-r--r--meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
index d04ea88..20c32cd 100644
--- a/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ b/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -112,6 +112,8 @@ RDEPENDS_${PN} = " libcrypto \
lshw \
jq \
"
+export SOTA_VERSION = "${PV}"
+
do_compile_prepend() {
# Fetch and build the specific build of hyper that is specified in cargo.toml.
# meta-rust doesn't support fetching crates that don't point to a specific tag
@@ -134,6 +136,5 @@ do_install() {
install -c ${S}/run/sota_client.service ${D}${systemd_unitdir}/system
install -d ${D}${sysconfdir}
- echo `git log -1 --pretty=format:%H` > ${D}${sysconfdir}/sota_client.version
install -c ${S}/run/sota_certificates ${D}${sysconfdir}
}