summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2016-12-07 19:58:18 +0100
committerRonan <ronan.lemartret@iot.bzh>2016-12-07 19:58:18 +0100
commit9e930f505a214be4a2c5f1a6f68c542d301a62e8 (patch)
tree5090169d1d28d67bd771ca2a28a635b28bb43646
parentc2210c4e55cdac87122acff7123c45e7dcd0d4dc (diff)
add native build for af-main
Change-Id: If9765fa5dbb5229a511b36cda83505cab75e7785 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index 1b4e209..611307f 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -7,16 +7,27 @@ require af-main_${PV}.inc
# NOTE: using ZIP programs creates directories with mode 777 (very bad)
inherit cmake pkgconfig useradd systemd
+BBCLASSEXTEND = "native"
SECTION = "base"
DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c security-manager libcap-native af-binder"
+DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip"
afm_name = "afm"
afm_confdir = "${sysconfdir}/${afm_name}"
afm_datadir = "${datadir}/${afm_name}"
afb_binding_dir = "${libdir}/afb"
+EXTRA_OECMAKE_class-native = "\
+ -DUSE_LIBZIP=1 \
+ -DUSE_SIMULATION=1 \
+ -DUSE_SDK=1 \
+ -Dafm_name=${afm_name} \
+ -Dafm_confdir=${afm_confdir} \
+ -Dafm_datadir=${afm_datadir} \
+"
+
EXTRA_OECMAKE = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=0 \