summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-11-21 15:37:32 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2016-11-21 15:37:32 +0100
commitf45014a50e1895cdaa3771b1245a87253ea929bf (patch)
tree1afa14c24a75d473f6fd82abab0adb0dd5278c5e
parentd1c5151b80a13ac0d17b20a7e38453ab96c1a703 (diff)
Improves places for QT_WAYLAND_SHELL_INTEGRATION
This define is currently needed by all applications launched by the framework. This commits allows that. Change-Id: Ia56268c1bca58f2da7c0152fa735751603d799bc Signed-off-by: José Bollo <jose.bollo@iot.bzh>
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main/add-qt-wayland-shell-integration.patch24
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb7
-rwxr-xr-xmeta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime1
3 files changed, 29 insertions, 3 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main/add-qt-wayland-shell-integration.patch b/meta-app-framework/recipes-core/af-main/af-main/add-qt-wayland-shell-integration.patch
new file mode 100644
index 0000000..f8940f2
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-main/af-main/add-qt-wayland-shell-integration.patch
@@ -0,0 +1,24 @@
+diff --git a/conf/afm-user-daemon.service b/conf/afm-user-daemon.service
+index 6b5c1d8..e0f6799 100644
+--- a/conf/afm-user-daemon.service
++++ b/conf/afm-user-daemon.service
+@@ -7,6 +7,7 @@ BusName=org.AGL.afm.user
+ ExecStart=/usr/bin/afm-user-daemon --user-dbus=unix:path=%t/bus
+ Environment=AFM_APP_INSTALL_DIR=%%r
+ Environment=LD_PRELOAD=/usr/lib/libEGL.so
++Environment=QT_WAYLAND_SHELL_INTEGRATION=ivi-shell
+ Restart=on-failure
+ RestartSec=5
+
+diff --git a/docs/quick-tutorial.md b/docs/quick-tutorial.md
+index 081dfe5..f55d4d0 100644
+--- a/docs/quick-tutorial.md
++++ b/docs/quick-tutorial.md
+@@ -29,6 +29,7 @@ Using the CLI tool
+
+ ### Setup Environment
+ Connect your AGL target board to the network and copy some sample widgets on it through SSH (set BOARDIP with your board IP address) :
++
+ ```
+ $ cd afm-widget-examples
+ $ BOARDIP=1.2.3.4
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index d8d7af4..1b4e209 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -42,8 +42,11 @@ FILES_${PN} += "\
RDEPENDS_${PN}_append_smack = " smack-userspace"
DEPENDS_append_smack = " smack-userspace-native"
-# short hack here
-SRC_URI += " file://Hack-to-allow-the-debugging.patch"
+# short hacks here
+SRC_URI += "\
+ file://Hack-to-allow-the-debugging.patch \
+ file://add-qt-wayland-shell-integration.patch \
+"
do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
index 0b86044..ca712e1 100755
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
+++ b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
@@ -1,3 +1,2 @@
#!/bin/sh
-export QT_WAYLAND_SHELL_INTEGRATION="ivi-shell"
exec /usr/bin/qt5/qmlscene "$1" /usr/bin/web-runtime-webkit.qml