summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-18 15:38:47 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2017-01-18 15:38:47 +0000
commit4ab1e3bf22d0afbe5c47322b2e727fdf1f0097d7 (patch)
tree4c797f09f76fc4fe43aae4700ad17bd544ca16c0
parent22a19e912214d2a35050e95832b88cf4a6116954 (diff)
parentc823e902fa2ba32cbff87c73d479d3b2e34b4645 (diff)
Merge "Changes to pseudo have been merged into poky, this recipe is no more needed."
-rw-r--r--meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch40
-rw-r--r--meta-sota/recipes-devtools/pseudo/files/fallback-group2
-rw-r--r--meta-sota/recipes-devtools/pseudo/files/fallback-passwd1
-rw-r--r--meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb20
4 files changed, 0 insertions, 63 deletions
diff --git a/meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch b/meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch
deleted file mode 100644
index 3da2ad7..0000000
--- a/meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 41bb6c818a7ec9eeb33b60302c55c9c5ee393c5f Mon Sep 17 00:00:00 2001
-From: Anton Gerasimov <anton@advancedtelematic.com>
-Date: Fri, 30 Sep 2016 17:12:19 +0200
-Subject: [PATCH 1/1] Add check for existence of old file to renameat
-
----
- ports/unix/guts/renameat.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/ports/unix/guts/renameat.c b/ports/unix/guts/renameat.c
-index ade0509..d5e36fa 100644
---- a/ports/unix/guts/renameat.c
-+++ b/ports/unix/guts/renameat.c
-@@ -11,6 +11,7 @@
- int oldrc, newrc;
- int save_errno;
- int old_db_entry = 0;
-+ int may_unlinked = 0;
-
- pseudo_debug(PDBGF_FILE, "renameat: %d,%s->%d,%s\n",
- olddirfd, oldpath ? oldpath : "<nil>",
-@@ -44,10 +45,14 @@
- /* as with unlink, we have to mark that the file may get deleted */
- msg = pseudo_client_op(OP_MAY_UNLINK, 0, -1, newdirfd, newpath, newrc ? NULL : &newbuf);
- if (msg && msg->result == RESULT_SUCCEED)
-+ may_unlinked = 1;
-+ msg = pseudo_client_op(OP_STAT, 0, -1, olddirfd, oldpath, oldrc ? NULL : &oldbuf);
-+ if (msg && msg->result == RESULT_SUCCEED)
- old_db_entry = 1;
-+
- rc = real_renameat(olddirfd, oldpath, newdirfd, newpath);
- save_errno = errno;
-- if (old_db_entry) {
-+ if (may_unlinked) {
- if (rc == -1) {
- /* since we failed, that wasn't really unlinked -- put
- * it back.
---
-2.9.3
-
diff --git a/meta-sota/recipes-devtools/pseudo/files/fallback-group b/meta-sota/recipes-devtools/pseudo/files/fallback-group
deleted file mode 100644
index 81bf732..0000000
--- a/meta-sota/recipes-devtools/pseudo/files/fallback-group
+++ /dev/null
@@ -1,2 +0,0 @@
-root:*:0:
-mail:*:8:
diff --git a/meta-sota/recipes-devtools/pseudo/files/fallback-passwd b/meta-sota/recipes-devtools/pseudo/files/fallback-passwd
deleted file mode 100644
index c1458dc..0000000
--- a/meta-sota/recipes-devtools/pseudo/files/fallback-passwd
+++ /dev/null
@@ -1 +0,0 @@
-root::0:0:root:/home/root:/bin/sh
diff --git a/meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb b/meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb
deleted file mode 100644
index 211439e..0000000
--- a/meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-require recipes-devtools/pseudo/pseudo.inc
-
-SRC_URI = " \
- http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \
- file://fallback-passwd \
- file://fallback-group \
- file://0001-Add-check-for-existence-of-old-file-to-renameat.patch \
-"
-
-SRC_URI[md5sum] = "ee38e4fb62ff88ad067b1a5a3825bac7"
-SRC_URI[sha256sum] = "dac4ad2d21228053151121320f629d41dd5c0c87695ac4e7aea286c414192ab5"
-
-PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
-
-do_install_append_class-native () {
- install -d ${D}${sysconfdir}
- # The fallback files should never be modified
- install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
- install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
-}