summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-02-09 17:41:25 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2017-02-09 17:41:25 +0100
commit5a7b27c47f1cd51b21f17e38a8abce5504d78471 (patch)
treef028f42918195f8221bd193f875ca595d6b272a8
parent9153078094ced14ad313fdafde302ba385d9a6b6 (diff)
Update sota software
Update includes: - latest version of OSTree (2017.1) - latest versions of sota-client and sota-tools - fix for lshw recipe under morty Change-Id: Ic65fbf1cb0608143e49dc5d241b7d84940126e26 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb4
-rw-r--r--meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb149
-rw-r--r--meta-sota/recipes-sota/sota-tools/sota-tools_git.bb2
-rw-r--r--meta-sota/recipes-support/lshw/files/ldflags.patch42
-rw-r--r--meta-sota/recipes-support/lshw/lshw_02.16.bb4
5 files changed, 120 insertions, 81 deletions
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
index c48e398..dcd15e1 100644
--- a/meta-sota/recipes-sota/ostree/ostree_git.bb
+++ b/meta-sota/recipes-sota/ostree/ostree_git.bb
@@ -8,7 +8,7 @@ INHERIT_remove_class-native = "systemd"
SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
-SRCREV="37c07d2f1c90b12bcfba85a7d900f81a7c362eb4"
+SRCREV="6517a8a27a1386e7cb5482e7cb2919fe92721ccf"
S = "${WORKDIR}/git"
@@ -41,7 +41,7 @@ export STAGING_LIBDIR
do_configure() {
unset docdir
- NOCONFIGURE=true ./autogen.sh
+ NOCONFIGURE=1 ./autogen.sh
oe_runconf
}
diff --git a/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
index 8a9d8ce..4d10b47 100644
--- a/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ b/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -6,133 +6,128 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
inherit cargo systemd
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "sota_client.service"
-
S = "${WORKDIR}/git"
-SRCREV = "fe04468871d3d6b784eabc507ed68cef80b4dea1"
+SRCREV = "022cf8501f9eb84bf334a2490e6e0c67842882ab"
# Generate with:
# git describe --tags | cut -b2-
-PV = "v0.2.22-4-g72e6096"
+PV = "0.2.30-2-g022cf85"
BBCLASSEXTEND = "native"
FILES_${PN} = " \
${bindir}/sota_client \
- ${bindir}/sota_start.sh \
${bindir}/sota_sysinfo.sh \
+ ${bindir}/system_info.sh \
+ ${bindir}/sota_ostree.sh \
${sysconfdir}/sota_client.version \
${sysconfdir}/sota_certificates \
- ${systemd_system_unitdir}/sota_client.service \
- ${bindir}/sota_ostree.sh \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/sota_client.service', '', d)} \
"
SRC_URI = " \
crate://crates.io/aho-corasick/0.5.3 \
-crate://crates.io/time/0.1.35 \
-crate://crates.io/url/1.2.3 \
-crate://crates.io/ws2_32-sys/0.2.1 \
-crate://crates.io/hyper/0.9.14 \
-crate://crates.io/log/0.3.6 \
-crate://crates.io/unicase/1.4.0 \
-crate://crates.io/bitflags/0.7.0 \
crate://crates.io/bit-set/0.2.0 \
-crate://crates.io/lazy_static/0.2.2 \
-crate://crates.io/lazy_static/0.1.16 \
-crate://crates.io/rust-crypto/0.2.36 \
-crate://crates.io/typeable/0.1.2 \
-crate://crates.io/pkg-config/0.3.8 \
-crate://crates.io/httparse/1.2.1 \
-crate://crates.io/openssl/0.9.3 \
-crate://crates.io/user32-sys/0.2.0 \
-crate://crates.io/regex/0.1.80 \
-crate://crates.io/unicode-normalization/0.1.2 \
-crate://crates.io/idna/0.1.0 \
-crate://crates.io/unicode-bidi/0.2.3 \
-crate://crates.io/rand/0.3.15 \
-crate://crates.io/gcc/0.3.40 \
+crate://crates.io/bit-vec/0.4.3 \
+crate://crates.io/bitflags/0.4.0 \
+crate://crates.io/bitflags/0.7.0 \
+crate://crates.io/bytes/0.3.0 \
+crate://crates.io/cfg-if/0.1.0 \
+crate://crates.io/chan-signal/0.1.7 \
crate://crates.io/chan/0.1.18 \
-crate://crates.io/kernel32-sys/0.2.2 \
-crate://crates.io/winapi/0.2.8 \
+crate://crates.io/cookie/0.2.5 \
crate://crates.io/crossbeam/0.2.10 \
-crate://crates.io/bitflags/0.4.0 \
-crate://crates.io/thread-id/2.0.0 \
-crate://crates.io/mime/0.2.2 \
-crate://crates.io/thread_local/0.2.7 \
-crate://crates.io/utf8-ranges/0.1.3 \
-crate://crates.io/net2/0.2.26 \
crate://crates.io/dbus/0.4.1 \
-crate://crates.io/winapi-build/0.1.1 \
-crate://crates.io/chan-signal/0.1.7 \
-crate://crates.io/bit-vec/0.4.3 \
-crate://crates.io/toml/0.2.1 \
-crate://crates.io/quick-error/0.2.2 \
-crate://crates.io/ws/0.5.3 \
-crate://crates.io/traitobject/0.0.1 \
-crate://crates.io/cfg-if/0.1.0 \
-crate://crates.io/matches/0.1.4 \
+crate://crates.io/env_logger/0.3.5 \
+crate://crates.io/gcc/0.3.40 \
+crate://crates.io/gdi32-sys/0.2.0 \
crate://crates.io/getopts/0.2.14 \
-crate://crates.io/sha1/0.2.0 \
-crate://crates.io/openssl-sys/0.9.3 \
-crate://crates.io/cookie/0.2.5 \
-crate://crates.io/libressl-pnacl-sys/2.1.6 \
+crate://crates.io/hpack/0.2.0 \
+crate://crates.io/httparse/1.2.1 \
+crate://crates.io/hyper/0.9.14 \
+crate://crates.io/idna/0.1.0 \
+crate://crates.io/kernel32-sys/0.2.2 \
crate://crates.io/language-tags/0.2.2 \
-crate://crates.io/semver/0.1.20 \
-crate://crates.io/unix_socket/0.5.0 \
+crate://crates.io/lazy_static/0.1.16 \
+crate://crates.io/lazy_static/0.2.2 \
+crate://crates.io/lazycell/0.4.0 \
+crate://crates.io/libc/0.2.18 \
+crate://crates.io/log/0.3.6 \
+crate://crates.io/matches/0.1.4 \
crate://crates.io/memchr/0.1.11 \
-crate://crates.io/gdi32-sys/0.2.0 \
-crate://crates.io/nom/1.2.4 \
+crate://crates.io/mime/0.2.2 \
crate://crates.io/mio/0.6.1 \
-crate://crates.io/tempdir/0.3.5 \
crate://crates.io/miow/0.1.4 \
-crate://crates.io/pnacl-build-helper/1.4.10 \
-crate://crates.io/libc/0.2.18 \
+crate://crates.io/net2/0.2.26 \
crate://crates.io/nix/0.7.0 \
+crate://crates.io/nom/1.2.4 \
+crate://crates.io/num_cpus/1.2.0 \
+crate://crates.io/openssl-sys/0.9.3 \
+crate://crates.io/openssl/0.9.3 \
+crate://crates.io/pkg-config/0.3.8 \
+crate://crates.io/rand/0.3.15 \
+crate://crates.io/regex-syntax/0.3.9 \
+crate://crates.io/regex/0.1.80 \
+crate://crates.io/rust-crypto/0.2.36 \
+crate://crates.io/rustc-serialize/0.3.22 \
crate://crates.io/rustc_version/0.1.7 \
+crate://crates.io/semver/0.1.20 \
+crate://crates.io/sha1/0.2.0 \
crate://crates.io/slab/0.3.0 \
-crate://crates.io/rustc-serialize/0.3.22 \
-crate://crates.io/env_logger/0.3.5 \
-crate://crates.io/vecio/0.1.0 \
-crate://crates.io/rotor/0.6.3 \
-crate://crates.io/openssl-sys-extras/0.7.14 \
-crate://crates.io/regex-syntax/0.3.9 \
-crate://crates.io/bytes/0.3.0 \
-crate://crates.io/void/1.0.2 \
-crate://crates.io/spmc/0.2.1 \
-crate://crates.io/openssl-verify/0.1.0 \
-crate://crates.io/num_cpus/1.2.0 \
crate://crates.io/solicit/0.4.4 \
-crate://crates.io/lazycell/0.4.0 \
-crate://crates.io/hpack/0.2.0 \
-crate-index://crates.io/7670a5aa394d0dcd7598905b352d1634ca74d84a \
-git://github.com/advancedtelematic/rvi_sota_client.git;protocol=https \
+crate://crates.io/thread-id/2.0.0 \
+crate://crates.io/thread_local/0.2.7 \
+crate://crates.io/time/0.1.35 \
+crate://crates.io/toml/0.2.1 \
+crate://crates.io/traitobject/0.0.1 \
+crate://crates.io/typeable/0.1.2 \
+crate://crates.io/unicase/1.4.0 \
+crate://crates.io/unicode-bidi/0.2.3 \
+crate://crates.io/unicode-normalization/0.1.2 \
+crate://crates.io/unix_socket/0.5.0 \
+crate://crates.io/url/1.2.3 \
+crate://crates.io/user32-sys/0.2.0 \
+crate://crates.io/utf8-ranges/0.1.3 \
+crate://crates.io/void/1.0.2 \
+crate://crates.io/winapi-build/0.1.1 \
+crate://crates.io/winapi/0.2.8 \
+crate://crates.io/ws/0.5.3 \
+crate://crates.io/ws2_32-sys/0.2.1 \
+git://github.com/advancedtelematic/rvi_sota_client \
+crate-index://crates.io/213b1a455d9270888c03a42c8d29975369102caa \
"
-
SRC_URI[index.md5sum] = "79f10f436dbf26737cc80445746f16b4"
SRC_URI[index.sha256sum] = "86114b93f1f51aaf0aec3af0751d214b351f4ff9839ba031315c1b19dcbb1913"
-DEPENDS += " openssl dbus "
+SYSTEMD_SERVICE_${PN} = "sota_client.service"
+
+DEPENDS += " openssl "
RDEPENDS_${PN} = " libcrypto \
libssl \
+ dbus \
bash \
lshw \
jq \
"
-export SOTA_VERSION = "${PV}"
+
+do_compile_prepend() {
+ export SOTA_VERSION=$(make sota-version)
+}
do_install() {
install -d ${D}${bindir}
install -m 0755 target/${TARGET_SYS}/release/sota_client ${D}${bindir}
- install -m 0755 run/sota_start.sh ${D}${bindir}
install -m 0755 run/sota_sysinfo.sh ${D}${bindir}
+ ln -fs ${bindir}/sota_sysinfo.sh ${D}${bindir}/system_info.sh # For compatibilty with old sota.toml files
install -m 0755 run/sota_ostree.sh ${D}${bindir}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${S}/run/sota_client_ostree.service ${D}${systemd_system_unitdir}/sota_client.service
+ install -d ${D}${systemd_unitdir}/system
+ install -c ${S}/run/sota_client_ostree.service ${D}${systemd_unitdir}/system/sota_client.service
fi
install -d ${D}${sysconfdir}
+ echo `git log -1 --pretty=format:%H` > ${D}${sysconfdir}/sota_client.version
install -c ${S}/run/sota_certificates ${D}${sysconfdir}
}
diff --git a/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb b/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
index ef6c3a0..e472ff8 100644
--- a/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
+++ b/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
S = "${WORKDIR}/git"
SRC_URI = "gitsm://github.com/advancedtelematic/sota-tools.git;branch=master"
-SRCREV = "7d7c7850f35743d82862a70f643c5c3ddc5b296c"
+SRCREV = "c6ecec3e86c423dd6caaa362a5ff0a1a6f4072a8"
inherit cmake
diff --git a/meta-sota/recipes-support/lshw/files/ldflags.patch b/meta-sota/recipes-support/lshw/files/ldflags.patch
new file mode 100644
index 0000000..83e0410
--- /dev/null
+++ b/meta-sota/recipes-support/lshw/files/ldflags.patch
@@ -0,0 +1,42 @@
+diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.16/src/Makefile
+--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100
++++ lshw-B.02.16/src/Makefile 2017-02-07 16:22:45.578588072 +0100
+@@ -25,9 +25,9 @@
+ ifeq ($(SQLITE), 1)
+ CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
+ endif
+-LDFLAGS=-L./core/ -g
++LDEXTRAS=-L./core/ -g
+ ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
+- LDFLAGS+= -Wl,--as-needed
++ LDEXTRAS+= -Wl,--as-needed
+ endif
+ LDSTATIC=-static
+ LIBS=-llshw -lresolv
+@@ -37,7 +37,7 @@
+
+ export CXXFLAGS
+ export LIBS
+-export LDFLAGS
++export LDEXTRAS
+
+ DATAFILES = pci.ids usb.ids oui.txt manuf.txt
+
+@@ -51,7 +51,7 @@
+ +make -C core all
+
+ $(PACKAGENAME): core $(PACKAGENAME).o
+- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
++ $(CXX) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
+
+ .PHONY: po
+ po:
+@@ -69,7 +69,7 @@
+ static: $(PACKAGENAME)-static
+
+ $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
+- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
++ $(CXX) $(LDSTATIC) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
+ $(STRIP) $@
+
+ .PHONY: compressed
diff --git a/meta-sota/recipes-support/lshw/lshw_02.16.bb b/meta-sota/recipes-support/lshw/lshw_02.16.bb
index 3a61dab..677c6da 100644
--- a/meta-sota/recipes-support/lshw/lshw_02.16.bb
+++ b/meta-sota/recipes-support/lshw/lshw_02.16.bb
@@ -17,7 +17,9 @@ COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
PR="r1"
SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
- file://cross-compile.patch"
+ file://cross-compile.patch \
+ file://ldflags.patch \
+ "
SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d"
SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb"