summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhong Tran <tranmanphong@gmail.com>2017-02-23 23:41:45 +0700
committerPhong Tran <tranmanphong@gmail.com>2017-02-23 23:46:24 +0700
commitd3a02ef21fbd35bebcfba237d60d44eaddd0b3ab (patch)
tree86763de460b50b4ba7172cd8c8ae768cacd89982
parentd36e6359daed13ed4e55b00358da52648388fa7d (diff)
Fix the error of homescreen for QEMU x86-64
libEGL.so is not availabe in QEMU x86-64 env. This make the afm-user-daemon service is loaded failure. This make the homescreen fail to load. Remove LD_PRELOAD of libEGL.so for QEMU x86-64. Change-Id: Iba9a904cc7e4000861ec0e0d6f5c22f48428b954 Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index 7819bfa..1ea8b15 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -82,6 +82,10 @@ do_install_append() {
install -m 0755 ${WORKDIR}/afm-install ${D}${bindir}
}
+do_install_append_qemux86-64() {
+ sed -i -e '/LD_PRELOAD=\/usr\/lib\/libEGL.so/d' ${D}${systemd_user_unitdir}/afm-user-daemon.service
+}
+
do_install_append_smack () {
install -d ${D}/${sysconfdir}/smack/accesses.d
cat > ${D}/${sysconfdir}/smack/accesses.d/default-access-domains-no-user <<EOF