summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-13 16:55:20 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-13 16:55:20 +0000
commit579b0510817f032df5dc52125c34812f77ab85cb (patch)
treea26b2711e430176b203b57d9c66554a0359910d0
parentf1d47329d9fd83d6554434479ed0ba36797401bf (diff)
parentdc1d7d8b099aaca2ded66dda1cced67d275f13f6 (diff)
Merge "ostree_git.bb: Bug fixes"
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
index 37a2445..e085df0 100644
--- a/meta-sota/recipes-sota/ostree/ostree_git.bb
+++ b/meta-sota/recipes-sota/ostree/ostree_git.bb
@@ -22,11 +22,19 @@ FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
BBCLASSEXTEND = "native"
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
do_configure() {
NOCONFIGURE=true ./autogen.sh
oe_runconf
}
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
@@ -37,5 +45,9 @@ do_install_append() {
SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
FILES_${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/OSTree-1.0.gir \
${libdir}/dracut/ \
+ ${libdir}/girepository-1.0 \
+ ${libdir}/girepository-1.0/OSTree-1.0.typelib \
"