summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-08-19 18:13:24 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-08-19 18:14:32 +0200
commit69d6b7adc9aef8d39ca66ef8688ac968876ae040 (patch)
tree72cf660089eac75377d5ffc79d732386791ab15d
parentd7b72388c217690f31c615700573e46413680907 (diff)
Replaced functionality in qemux86-ota machine with algsetup.sh feature. otaimg is now a live image.
Bug-AGL: SPEC-236 Change-Id: I5a56ffbdb098c1b4eb33fceeae32e28611b83fb7 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
-rw-r--r--meta-sota/classes/image_types_ota.bbclass23
-rw-r--r--meta-sota/conf/machine/qemux86-ota.conf37
-rw-r--r--meta-sota/recipes-bsp/u-boot/u-boot-ota/0001-Set-up-environment-for-OSTree-integration.patch (renamed from meta-sota/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch)0
-rw-r--r--meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb (renamed from meta-sota/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb)9
-rw-r--r--templates/feature/agl-sota/50_local.conf.inc12
5 files changed, 33 insertions, 48 deletions
diff --git a/meta-sota/classes/image_types_ota.bbclass b/meta-sota/classes/image_types_ota.bbclass
index a67cc80..9820724 100644
--- a/meta-sota/classes/image_types_ota.bbclass
+++ b/meta-sota/classes/image_types_ota.bbclass
@@ -1,6 +1,6 @@
# Image to use with u-boot as BIOS and OSTree deployment system
-inherit image_types
+#inherit image_types
# Boot filesystem size in MiB
# OSTree updates may require some space on boot file system for
@@ -9,12 +9,15 @@ inherit image_types
BOOTFS_EXTRA_SIZE ?= "512"
export BOOTFS_EXTRA_SIZE
-IMAGE_TYPES += " otaimg"
-IMAGE_DEPENDS_ota = "e2fsprogs-native \
- virtual/bootloader \
- virtual/kernel \
- parted-native \
- ${INITRD_IMAGE}"
+do_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \
+ parted-native:do_populate_sysroot \
+ virtual/kernel:do_deploy \
+ ${INITRD_IMAGE}:do_rootfs \
+ ${PN}:do_rootfs"
+
+ROOTFS ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_BASENAME}-${MACHINE}.ext4"
+INITRD_IMAGE ?= "core-image-minimal-initramfs"
+INITRD ?= "${DEPLOY_DIR_IMAGE}/${INITRD_IMAGE}-${MACHINE}.cpio.gz"
build_bootfs () {
KERNEL_FILE=${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}
@@ -36,7 +39,7 @@ build_bootfs () {
rm -rf $BOOTTMP
}
-IMAGE_CMD_otaimg () {
+do_otaimg () {
BOOTIMG=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.otaboot.ext4
rm -f $BOOTIMG
build_bootfs $BOOTIMG
@@ -70,4 +73,8 @@ IMAGE_CMD_otaimg () {
ln -s ${IMAGE_NAME}.otaimg ${IMAGE_LINK_NAME}.otaimg
}
+addtask otaimg before do_build
+
+IMAGE_TYPES += " otaimg"
+IMAGE_TYPES_MASKED += "otaimg"
IMAGE_TYPEDEP_otaimg = "ext4"
diff --git a/meta-sota/conf/machine/qemux86-ota.conf b/meta-sota/conf/machine/qemux86-ota.conf
deleted file mode 100644
index 3c58870..0000000
--- a/meta-sota/conf/machine/qemux86-ota.conf
+++ /dev/null
@@ -1,37 +0,0 @@
-#@TYPE: Machine
-#@NAME: common_pc
-#@DESCRIPTION: Machine configuration for running a common x86
-
-PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
-PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
-
-require conf/machine/include/qemu.inc
-require conf/machine/include/tune-i586.inc
-
-KERNEL_IMAGETYPE = "bzImage"
-
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-buildrom"
-UBOOT_MACHINE = "qemu-x86_defconfig"
-
-IMAGE_CLASSES += "image_types_ota"
-IMAGE_FSTYPES += "otaimg"
-
-SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
-
-XSERVER = "xserver-xorg \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \
- xf86-input-vmmouse \
- xf86-input-keyboard \
- xf86-input-evdev \
- xf86-video-cirrus \
- xf86-video-fbdev \
- xf86-video-vmware"
-
-MACHINE_FEATURES += "x86"
-
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "v86d"
-
-MACHINEOVERRIDES .= ":qemux86"
-KMACHINE = "qemux86"
diff --git a/meta-sota/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch b/meta-sota/recipes-bsp/u-boot/u-boot-ota/0001-Set-up-environment-for-OSTree-integration.patch
index c33d40c..c33d40c 100644
--- a/meta-sota/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch
+++ b/meta-sota/recipes-bsp/u-boot/u-boot-ota/0001-Set-up-environment-for-OSTree-integration.patch
diff --git a/meta-sota/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb b/meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb
index 7e3c67f..8f0b20a 100644
--- a/meta-sota/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb
+++ b/meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb
@@ -13,7 +13,10 @@ SRC_URI += "file://0001-Set-up-environment-for-OSTree-integration.patch"
PV = "v2016.07+git${SRCPV}"
-EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
-
-UBOOT_SUFFIX = "rom"
+EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline"
+EXTRA_OEMAKE_append_qemux86 = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
+EXTRA_OEMAKE_append_qemux86-64 = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
+UBOOT_SUFFIX = "bin"
+UBOOT_SUFFIX_qemux86 = "rom"
+UBOOT_SUFFIX_qemux86-64 = "rom"
diff --git a/templates/feature/agl-sota/50_local.conf.inc b/templates/feature/agl-sota/50_local.conf.inc
new file mode 100644
index 0000000..a27d7af
--- /dev/null
+++ b/templates/feature/agl-sota/50_local.conf.inc
@@ -0,0 +1,12 @@
+DISTRO_FEATURES_append = " agl-ota"
+
+# live image for OSTree-enabled systems
+IMAGE_CLASSES += "image_types_ota"
+IMAGE_FSTYPES += "otaimg"
+
+UBOOT_MACHINE_qemux86 = "qemu-x86_defconfig"
+UBOOT_MACHINE_qemux86_64 = "qemu-x86_defconfig"
+
+PREFERRED_PROVIDER_virtual/bootloader_qemux86 ?= "u-boot-ota"
+PREFERRED_PROVIDER_virtual/bootloader_qemux86-64 ?= "u-boot-ota"
+