summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:00:02 +0300
committerLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:20:28 +0300
commit9c574f0620df81c8e59f767e60fed46fab478d5e (patch)
treebc3fe4a60e39d1e8ebb592ec5a44870493f8cff7
parent7fa21fc6131f0af27185077091a3a8f1de73d625 (diff)
libgsystem_git.bb: Bug fixes
Fixes for LibGSystem recipe: * Export staging directories, host and build system, * Deploy installed files in /usr/lib and /usr/share. Bug-AGL: SPEC-194 Change-Id: I9e564088d545525c791426f6a80a870f5b6b45b5 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--meta-sota/recipes-sota/libgsystem/libgsystem_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb b/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
index f35819d..fe1e552 100644
--- a/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
+++ b/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
@@ -15,7 +15,23 @@ inherit autotools-brokensep
BBCLASSEXTEND += "native"
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
do_configure() {
NOCONFIGURE=true ./autogen.sh
oe_runconf
}
+
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
+FILES_${PN} += " \
+ ${datadir} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/GSystem-1.0.gir \
+ ${libdir}/girepository-1.0/ \
+ ${libdir}/girepository-1.0/GSystem-1.0.typelib \
+"