summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:03:45 +0300
committerLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:20:40 +0300
commitdc1d7d8b099aaca2ded66dda1cced67d275f13f6 (patch)
treeb9191d813e79ec0198f71361a3ef02006b2a8c78
parent9c574f0620df81c8e59f767e60fed46fab478d5e (diff)
ostree_git.bb: Bug fixes
Fixes for OSTree recipe: * Export staging directories, host and build system, * Deploy installed files in /usr/lib and /usr/share. Bug-AGL: SPEC-194 Change-Id: Ieda8c03f24c571827e91b0e72acad515f0cf14ff Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
index 37a2445..e085df0 100644
--- a/meta-sota/recipes-sota/ostree/ostree_git.bb
+++ b/meta-sota/recipes-sota/ostree/ostree_git.bb
@@ -22,11 +22,19 @@ FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
BBCLASSEXTEND = "native"
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
do_configure() {
NOCONFIGURE=true ./autogen.sh
oe_runconf
}
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
@@ -37,5 +45,9 @@ do_install_append() {
SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
FILES_${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/OSTree-1.0.gir \
${libdir}/dracut/ \
+ ${libdir}/girepository-1.0 \
+ ${libdir}/girepository-1.0/OSTree-1.0.typelib \
"