summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-13 16:55:13 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-13 16:55:14 +0000
commitf1d47329d9fd83d6554434479ed0ba36797401bf (patch)
treecc04b01d23a5f24c031a0e20800be9a175c6d067
parentaf691608a20d121153fb17f558dde319114e4f72 (diff)
parent9c574f0620df81c8e59f767e60fed46fab478d5e (diff)
Merge "libgsystem_git.bb: Bug fixes"
-rw-r--r--meta-sota/recipes-sota/libgsystem/libgsystem_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb b/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
index f35819d..fe1e552 100644
--- a/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
+++ b/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
@@ -15,7 +15,23 @@ inherit autotools-brokensep
BBCLASSEXTEND += "native"
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
do_configure() {
NOCONFIGURE=true ./autogen.sh
oe_runconf
}
+
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
+FILES_${PN} += " \
+ ${datadir} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/GSystem-1.0.gir \
+ ${libdir}/girepository-1.0/ \
+ ${libdir}/girepository-1.0/GSystem-1.0.typelib \
+"