summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-07-08 15:08:25 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2016-07-10 16:45:16 +0000
commitc664012d6a990813dcd4f7524c03e459c56eddf5 (patch)
treee6b599d0a486f88da6e4f56112c9298e6d17e7b1 /meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
parentd7a5a54fc04523801e37f83f16e0e5b1e4844188 (diff)
meta-app-framework: add af-main-tools and dependencies in nativesdk-packagegroup-sdk-host
This is required to install app framework sdk tools. Change-Id: Iad407420fa734c063926d1883c288af387155668 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb')
-rw-r--r--meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
new file mode 100644
index 0000000..426e999
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
@@ -0,0 +1,25 @@
+require af-main_${PV}.inc
+
+inherit nativesdk cmake pkgconfig
+
+SECTION = "base"
+
+DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip"
+
+afm_name = "afm"
+afm_confdir = "${sysconfdir}/${afm_name}"
+afm_datadir = "${datadir}/${afm_name}"
+
+EXTRA_OECMAKE = "\
+ -DUSE_LIBZIP=1 \
+ -DUSE_SIMULATION=1 \
+ -DUSE_SDK=1 \
+ -Dafm_name=${afm_name} \
+ -Dafm_confdir=${afm_confdir} \
+ -Dafm_datadir=${afm_datadir} \
+"
+
+PACKAGES = "${PN}-tools ${PN}-tools-dbg"
+FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
+FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
+