summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-03-08 13:15:58 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-03-08 18:54:12 +0100
commite159294ecd366d2b7c67e5a610f5e7f55381e908 (patch)
tree76500c157bdaddc3b051c4f3eebe70b372810e6a /meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
parentd19db324a31e8baa57043ac9135c505a7393a01c (diff)
Removes systemd warnings
Systemd was complaining that the service files were executable. This patch removes that issue. Change-Id: I77183bb142956fec84b3ca727f7084e8f652c292 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend')
-rw-r--r--meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
index 90f69eb..23ceb29 100644
--- a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
+++ b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
@@ -16,7 +16,7 @@ do_install_append () {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
mkdir -p ${D}${systemd_unitdir}/system
mkdir -p ${D}${sysconfdir}/systemd/system/default.target.wants
- install -p -D ${WORKDIR}/init-security-manager-db.service ${D}${systemd_unitdir}/system/init-security-manager-db.service
+ install -m 644 -p -D ${WORKDIR}/init-security-manager-db.service ${D}${systemd_unitdir}/system/init-security-manager-db.service
ln -sf ${systemd_unitdir}/system/init-security-manager-db.service ${D}${sysconfdir}/systemd/system/default.target.wants
fi
}