summaryrefslogtreecommitdiffstats
path: root/meta-attic/recipes-demo-hmi/vod-server
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-04-23 19:10:43 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-04-23 19:10:43 +0200
commit873b57dfbd7f67a762a8300a60278764b911c893 (patch)
tree34c7c5b09b8021e9e4b1846d100081e9d5f71aa9 /meta-attic/recipes-demo-hmi/vod-server
parent992ef6afe1798ee24df3ccbbe8309e8de9f2c183 (diff)
Cleanup post next mergesandbox/jsmoeller/cleanup
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: Ieee834f43877f0d675b4a97eebfcde1683fb0cef
Diffstat (limited to 'meta-attic/recipes-demo-hmi/vod-server')
-rw-r--r--meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch25
-rw-r--r--meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service10
-rw-r--r--meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb35
3 files changed, 70 insertions, 0 deletions
diff --git a/meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch b/meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch
new file mode 100644
index 0000000..c034d4e
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch
@@ -0,0 +1,25 @@
+--- a/buildX86/Makefile-Release.mk 2016-12-09 15:48:37.000000000 +0100
++++ b/buildX86/Makefile-Release.mk 2016-12-09 16:56:35.071740652 +0100
+@@ -11,14 +11,14 @@
+ MKDIR=mkdir
+ CP=cp
+ GREP=grep
+-NM=nm
+-CCADMIN=CCadmin
+-RANLIB=ranlib
+-CC=${CROSS_COMPILE}gcc
+-CCC=${CROSS_COMPILE}g++
+-CXX=${CROSS_COMPILE}g++
+-FC=${CROSS_COMPILE}gfortran
+-AS=${CROSS_COMPILE}as
++#NM=nm
++#CCADMIN=CCadmin
++#RANLIB=ranlib
++#CC=${CROSS_COMPILE}gcc
++#CCC=${CROSS_COMPILE}g++
++#CXX=${CROSS_COMPILE}g++
++#FC=${CROSS_COMPILE}gfortran
++#AS=${CROSS_COMPILE}as
+
+ # Macros
+ CND_PLATFORM=GNU-Linux-x86
diff --git a/meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service b/meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service
new file mode 100644
index 0000000..c783bd4
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Video On Demand AGL Demo
+After=WindowManager.service most-network-manager.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/VideoOnDemand -p /home/root/Video
+
+[Install]
+WantedBy=default.target
diff --git a/meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb
new file mode 100644
index 0000000..d1cbb66
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Build VideoOnDemand server"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+# "
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
+ file://vod-demo.service"
+
+S = "${WORKDIR}/git"
+SRCREV = "faafe61dd5f88859a005a59082d57339089ddca1"
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+
+ # Install VOD server systemd service (user)
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -m 644 -p -D ${WORKDIR}/vod-demo.service ${D}${systemd_user_unitdir}/vod-demo.service
+
+ # Execute install manually for root user on behalf of systemctl script
+ # because it doesn't support user mode of systemd.
+ install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
+ sed -i "s:/home/root:${ROOT_HOME}:" ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
+ fi
+}
+
+FILES_${PN} += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+ "