summaryrefslogtreecommitdiffstats
path: root/meta-attic/recipes-graphics/web-runtime/web-runtime_0.1.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-04-23 19:10:43 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-04-23 19:10:43 +0200
commit873b57dfbd7f67a762a8300a60278764b911c893 (patch)
tree34c7c5b09b8021e9e4b1846d100081e9d5f71aa9 /meta-attic/recipes-graphics/web-runtime/web-runtime_0.1.bb
parent992ef6afe1798ee24df3ccbbe8309e8de9f2c183 (diff)
Cleanup post next mergesandbox/jsmoeller/cleanup
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: Ieee834f43877f0d675b4a97eebfcde1683fb0cef
Diffstat (limited to 'meta-attic/recipes-graphics/web-runtime/web-runtime_0.1.bb')
-rw-r--r--meta-attic/recipes-graphics/web-runtime/web-runtime_0.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-attic/recipes-graphics/web-runtime/web-runtime_0.1.bb b/meta-attic/recipes-graphics/web-runtime/web-runtime_0.1.bb
new file mode 100644
index 0000000..ea5acbb
--- /dev/null
+++ b/meta-attic/recipes-graphics/web-runtime/web-runtime_0.1.bb
@@ -0,0 +1,37 @@
+inherit allarch
+
+SUMMARY = "Provides the 'web-runtime' command"
+DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "\
+ file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
+ file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
+ file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
+"
+
+RDEPENDS_${PN} = "\
+ qtdeclarative-tools \
+ qtwayland-qmlplugins \
+ qtquickcontrols-qmlplugins \
+ qtwebengine \
+ runxdg \
+ bash \
+"
+
+PROVIDES += "virtual/webruntime"
+# add also RPROVIDES to satisfy the packagegroup
+RPROVIDES_${PN} += "virtual/webruntime"
+
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
+ install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
+ install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
+}