summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-10-25 11:08:50 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-10-27 11:35:21 +0200
commit1b73e59ec2703605ad20ea7b42516cb382a5436a (patch)
tree1b5f5c79a1744f5af1faf9dfc93476282e3ad202 /meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
parenteadecc11aac1b0de7a0841213f647e35ccf5a6a1 (diff)
OSTree-enabled image for raspberry Pi
Bug-AGL: SPEC-254 v2 [jsmoeller]: change rpi fdt addr to 200M (fix cma), re-add inherit gobject-introspection (!) v3 [oytis]: move boot logic to editable uEnv.txt Change-Id: Ic54aadc8377ed1e2a8f2f4ab87db2a7a6660cd15 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb')
-rw-r--r--meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
new file mode 100644
index 0000000..9f5f0ca
--- /dev/null
+++ b/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Boot script for launching OTA-enabled images on raspberrypi"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS = "u-boot-mkimage-native"
+
+COMPATIBLE_MACHINE = "raspberrypi"
+
+SRC_URI = "file://boot.scr \
+ file://uEnv.txt"
+
+S = "${WORKDIR}"
+
+inherit deploy
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/bcm2835-bootfiles
+
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
+ install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
+}
+
+addtask deploy before do_package after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"