summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-04-24 13:59:21 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2017-04-24 13:59:21 +0200
commitabe6250af91c4b3193511f4dd5fbfb7ee40d76d5 (patch)
tree040bcd7509accf453145b2c0c77b06d8e35a13e9 /meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
parente4bc8c7058fbf27969a967a5e30f15fcf22544bd (diff)
Moved to meta-updater@github.com/advancedtelenmatic Change-Id: I7c89d373e43a88a89155c72de87c0b4b5238bc52 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb')
-rw-r--r--meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
deleted file mode 100644
index e2ccc43..0000000
--- a/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-DESCRIPTION = "Boot script for launching OTA-enabled images on raspberrypi"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-DEPENDS = "u-boot-mkimage-native"
-
-COMPATIBLE_MACHINE = "raspberrypi"
-
-SRC_URI = "file://boot.scr \
- file://uEnv.txt \
- file://uEnv.cma.txt \
- file://0001-fixup-build-with-gcc6.patch \
- "
-
-S = "${WORKDIR}"
-
-inherit deploy
-
-do_deploy() {
- install -d ${DEPLOYDIR}/bcm2835-bootfiles
-
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
- if [ "${ENABLE_CMA}" = "1" ]; then
- install -m 0755 ${S}/uEnv.cma.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
- else
- install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
- fi
-}
-
-addtask deploy before do_package after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"