summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-core
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-09-26 15:44:53 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-09-26 15:44:53 +0200
commit4e1566679067975e3e8ee0a9198e4df332e6e32e (patch)
tree9d0ca74f9868e22e878524aa6bfcebeb97a6990e /meta-sota/recipes-core
parent111007af41bd44d3b634563373fa7b04dc6aa2ae (diff)
Added initramfs image and fixed several error to make AGL rootfs
bootable as an OSTree deployment Bug-AGL: SPEC-253 Change-Id: If636a282d51a64c73c46ce70a361518c1f70cdd6 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-core')
-rw-r--r--meta-sota/recipes-core/images/initramfs-ostree-image.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-sota/recipes-core/images/initramfs-ostree-image.bb b/meta-sota/recipes-core/images/initramfs-ostree-image.bb
new file mode 100644
index 0000000..71aa631
--- /dev/null
+++ b/meta-sota/recipes-core/images/initramfs-ostree-image.bb
@@ -0,0 +1,23 @@
+# Netboot initramfs image.
+DESCRIPTION = "OSTree initramfs image"
+
+PACKAGE_INSTALL = "ostree ostree-initramfs systemd-initramfs busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+SYSTEMD_DEFAULT_TARGET = "initrd.target"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "initramfs-ostree-image"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
+
+