summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-10-04 14:42:42 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-10-04 14:42:42 +0200
commit689d2a8e825b3fc77bd4671f2c0597d2de5f0fdf (patch)
tree50da6e3b59d6e112c15eabd2a3d675d7334ab4ab /meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb
parent46b4d2dd4a44de0588426d69168415af3e01acac (diff)
Tuned initrd image and pseudo environment to fix bugs with extended
security attributes. Bug-AGL: SPEC-259 Change-Id: I44499ce3f5f1924aecf63689a93d1f20e779225e Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb')
-rw-r--r--meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb b/meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb
new file mode 100644
index 0000000..5c85bee
--- /dev/null
+++ b/meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Extremely basic live image init script"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+SRC_URI = "file://init.sh"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -dm 0755 ${D}/etc
+ touch ${D}/etc/initrd-release
+ install -dm 0755 ${D}/dev
+ install -dm 0755 ${D}/sbin
+ install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init
+}
+
+inherit allarch
+
+FILES_${PN} += " /dev /etc/initrd-release /sbin/init "
+