summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-07-05 16:31:07 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2016-07-05 20:52:56 +0000
commit994af16e7ac5a231467c35c258f7267d3d649816 (patch)
treeaf28085410184d47ef0f435f9d41d8bb905182d9 /meta-sota/recipes-sota/ostree/ostree_git.bb
parent68dde03cb5a5731e8d2b6e9fe9a4e5c2d1ae7e9a (diff)
added meta-sota, enabled by feature 'agl-sota'
Change-Id: I27100c94abdbd83f8514778c017f2d5e08b22e41 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-sota/recipes-sota/ostree/ostree_git.bb')
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
new file mode 100644
index 0000000..9009685
--- /dev/null
+++ b/meta-sota/recipes-sota/ostree/ostree_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SRC_URI = "gitsm://git.gnome.org/ostree.git;branch=master"
+SRCREV="${AUTOREV}"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4"
+
+RDEPENDS_${PN} = "python libsystemd util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma"
+
+inherit autotools-brokensep
+
+EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
+
+FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
+
+BBCLASSEXTEND = "native"
+
+do_configure() {
+ NOCONFIGURE=true ./autogen.sh
+ oe_runconf
+}