summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-11-08 11:23:19 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2016-11-08 18:43:07 +0100
commit06f1d5958e368eb35a96b95260a23ff887d27d0b (patch)
treec51680358ecd3f030b5bc2da408090ad26cfbc30 /meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
parenta70d7107e8f0dad2104f6b8eb295c722ce02309b (diff)
A tool for uploading OSTree objects to a server together with
integration code Bug-AGL: SPEC-194 Change-Id: I650e190bbda67ad48233bc5aedc0c10ff14aa58f Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-sota/sota-tools/sota-tools_git.bb')
-rw-r--r--meta-sota/recipes-sota/sota-tools/sota-tools_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb b/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
new file mode 100644
index 0000000..acd8e4a
--- /dev/null
+++ b/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Utility to push data to a server"
+LICENSE = "MPL-2.0"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "gitsm://github.com/advancedtelematic/sota-tools.git;branch=master"
+SRCREV = "7ff1d92c161ba4fb047a1e1e4cba5424b4adca00"
+
+inherit cmake
+
+DEPENDS = "boost"
+
+BBCLASSEXTEND = "native"
+
+FILES_${PN} = "${bindir}/garage-push"
+
+EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 755 garage-push ${D}/${bindir}
+}