summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-08 19:22:58 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2016-11-08 19:22:58 +0000
commitdbb8dfa077019a38037ff7c9a4316bfdde2391fb (patch)
tree0c3a6b15c45e9d9960fb04bd139d8d283646d8a5 /meta-sota/recipes-sota
parent3b8a56651fe1598c0c2e50a8c079f111ebb824fe (diff)
parent06f1d5958e368eb35a96b95260a23ff887d27d0b (diff)
Merge "A tool for uploading OSTree objects to a server together with integration code"
Diffstat (limited to 'meta-sota/recipes-sota')
-rw-r--r--meta-sota/recipes-sota/sota-tools/sota-tools_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb b/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
new file mode 100644
index 0000000..acd8e4a
--- /dev/null
+++ b/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Utility to push data to a server"
+LICENSE = "MPL-2.0"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "gitsm://github.com/advancedtelematic/sota-tools.git;branch=master"
+SRCREV = "7ff1d92c161ba4fb047a1e1e4cba5424b4adca00"
+
+inherit cmake
+
+DEPENDS = "boost"
+
+BBCLASSEXTEND = "native"
+
+FILES_${PN} = "${bindir}/garage-push"
+
+EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 755 garage-push ${D}/${bindir}
+}