summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-09-02 17:55:48 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-09-12 14:58:42 +0200
commit798818884c21a743f17e26eda22ceb433b69a3c1 (patch)
treeea6a3e33a44dc6824ca873f8e9172d859c8e95e1 /meta-sota/recipes-support/libgsystem/libgsystem_git.bb
parentc3d3de76193e0ac217635e0fc67e5ee70e33f46b (diff)
Build OSTree natively, and its dependencies as well
Bug-AGL: SPEC-245 Change-Id: Ia5631d786c3375ba3aa0bc6ac75ebaeb358e7b03 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-support/libgsystem/libgsystem_git.bb')
-rw-r--r--meta-sota/recipes-support/libgsystem/libgsystem_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-sota/recipes-support/libgsystem/libgsystem_git.bb b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
new file mode 100644
index 0000000..4b1eb49
--- /dev/null
+++ b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "GIO-based library, targeted primarily for use by operating system components"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SRC_URI = "gitsm://github.com/GNOME/libgsystem.git"
+SRCREV="d606bec68ddfea78de4b03c3f3568afb71bdc1ce"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep
+
+DEPENDS += "attr glib-2.0 pkgconfig libcap"
+RDEPENDS_${PN} = "xz systemd"
+
+RDEPENDS_${PN}_remove_class-native = "systemd-native"
+
+BBCLASSEXTEND = "native"
+
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+do_configure() {
+ NOCONFIGURE=true ./autogen.sh
+ oe_runconf
+}
+
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
+FILES_${PN} += " \
+ ${datadir} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/GSystem-1.0.gir \
+ ${libdir}/girepository-1.0/ \
+ ${libdir}/girepository-1.0/GSystem-1.0.typelib \
+"