summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-support/lshw/files/ldflags.patch
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-02-09 17:41:25 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2017-02-09 17:41:25 +0100
commit5a7b27c47f1cd51b21f17e38a8abce5504d78471 (patch)
treef028f42918195f8221bd193f875ca595d6b272a8 /meta-sota/recipes-support/lshw/files/ldflags.patch
parent9153078094ced14ad313fdafde302ba385d9a6b6 (diff)
Update sota software
Update includes: - latest version of OSTree (2017.1) - latest versions of sota-client and sota-tools - fix for lshw recipe under morty Change-Id: Ic65fbf1cb0608143e49dc5d241b7d84940126e26 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-support/lshw/files/ldflags.patch')
-rw-r--r--meta-sota/recipes-support/lshw/files/ldflags.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-sota/recipes-support/lshw/files/ldflags.patch b/meta-sota/recipes-support/lshw/files/ldflags.patch
new file mode 100644
index 0000000..83e0410
--- /dev/null
+++ b/meta-sota/recipes-support/lshw/files/ldflags.patch
@@ -0,0 +1,42 @@
+diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.16/src/Makefile
+--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100
++++ lshw-B.02.16/src/Makefile 2017-02-07 16:22:45.578588072 +0100
+@@ -25,9 +25,9 @@
+ ifeq ($(SQLITE), 1)
+ CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
+ endif
+-LDFLAGS=-L./core/ -g
++LDEXTRAS=-L./core/ -g
+ ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
+- LDFLAGS+= -Wl,--as-needed
++ LDEXTRAS+= -Wl,--as-needed
+ endif
+ LDSTATIC=-static
+ LIBS=-llshw -lresolv
+@@ -37,7 +37,7 @@
+
+ export CXXFLAGS
+ export LIBS
+-export LDFLAGS
++export LDEXTRAS
+
+ DATAFILES = pci.ids usb.ids oui.txt manuf.txt
+
+@@ -51,7 +51,7 @@
+ +make -C core all
+
+ $(PACKAGENAME): core $(PACKAGENAME).o
+- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
++ $(CXX) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
+
+ .PHONY: po
+ po:
+@@ -69,7 +69,7 @@
+ static: $(PACKAGENAME)-static
+
+ $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
+- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
++ $(CXX) $(LDSTATIC) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
+ $(STRIP) $@
+
+ .PHONY: compressed