summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-support/python-canonicaljson/python-canonicaljson.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-03-30 13:31:36 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2017-04-04 11:37:43 +0200
commit1c2571e37c6fa5e0ac3bb035173ae07a187648c5 (patch)
tree681d094eb924f1b5f7ecce6adbb08ce4e4eb2509 /meta-sota/recipes-support/python-canonicaljson/python-canonicaljson.bb
parent497d7db5bfc71367c6393a09a2f768b812fce83f (diff)
Update SOTA-related software
Support for grub2 has been added, rust's json parser temporarily replaced with python-canonicaljson because of compatibility issues. Change-Id: I6665ed3ad56afc90f0e82eb90993c8656be16d5f Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-support/python-canonicaljson/python-canonicaljson.bb')
-rw-r--r--meta-sota/recipes-support/python-canonicaljson/python-canonicaljson.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-sota/recipes-support/python-canonicaljson/python-canonicaljson.bb b/meta-sota/recipes-support/python-canonicaljson/python-canonicaljson.bb
new file mode 100644
index 0000000..d8a0728
--- /dev/null
+++ b/meta-sota/recipes-support/python-canonicaljson/python-canonicaljson.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "python-canonicaljson recipe"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRCREV = "92e2c06871cc275c2a8b8e3e899141a212aae0e8"
+SRC_URI = "git://github.com/matrix-org/python-canonicaljson.git"
+S = "${WORKDIR}/git"
+
+# Generate with:
+# git describe --tags | cut -b2-
+PV = "1.0.0"
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-simplejson \
+ python-frozendict \
+ "