summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-support
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-10-28 14:08:40 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-10-31 18:21:26 +0100
commitbbe9cf8fe9b1377e6f08c391df4308776d29e141 (patch)
tree01d309f441b157b4a42751825ff6efe282dcb730 /meta-sota/recipes-support
parent9df92779f86367df2dc0a794b1fb4ae954609b7d (diff)
Update rvi-sota-client
Change-Id: I1d5ceb776427298d46ab26dab2c822041dff00e0 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-sota/recipes-support')
-rw-r--r--meta-sota/recipes-support/libgit2/libgit2-release.inc2
-rw-r--r--meta-sota/recipes-support/libgit2/libgit2.inc19
-rw-r--r--meta-sota/recipes-support/libgit2/libgit2_0.24.1.bb4
-rw-r--r--meta-sota/recipes-support/libssh2/libssh2_%.bbappend2
-rw-r--r--meta-sota/recipes-support/lshw/files/cross-compile.patch39
-rw-r--r--meta-sota/recipes-support/lshw/lshw_02.16.bb36
6 files changed, 102 insertions, 0 deletions
diff --git a/meta-sota/recipes-support/libgit2/libgit2-release.inc b/meta-sota/recipes-support/libgit2/libgit2-release.inc
new file mode 100644
index 0000000..62a13cf
--- /dev/null
+++ b/meta-sota/recipes-support/libgit2/libgit2-release.inc
@@ -0,0 +1,2 @@
+require libgit2.inc
+SRC_URI = "https://github.com/libgit2/libgit2/archive/v${PV}.tar.gz"
diff --git a/meta-sota/recipes-support/libgit2/libgit2.inc b/meta-sota/recipes-support/libgit2/libgit2.inc
new file mode 100644
index 0000000..fe0f647
--- /dev/null
+++ b/meta-sota/recipes-support/libgit2/libgit2.inc
@@ -0,0 +1,19 @@
+SUMMARY = "the Git linkable library"
+HOMEPAGE = "http://libgit2.github.com/"
+LICENSE = "GPL-2.0-with-GCC-exception"
+
+DEPENDS = "openssl zlib"
+
+inherit cmake
+
+# CLAR = tests, needs python-native
+EXTRA_OECMAKE = "\
+ -DTHREADSAFE=ON \
+ -DBUILD_CLAR=OFF \
+ -DSHA1_TYPE="builtin" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DBUILD_SHARED_LIBS=OFF \
+ -DBUILD_EXAMPLES=OFF \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-sota/recipes-support/libgit2/libgit2_0.24.1.bb b/meta-sota/recipes-support/libgit2/libgit2_0.24.1.bb
new file mode 100644
index 0000000..2d0c6ff
--- /dev/null
+++ b/meta-sota/recipes-support/libgit2/libgit2_0.24.1.bb
@@ -0,0 +1,4 @@
+LIC_FILES_CHKSUM = "file://COPYING;md5=34197a479f637beb9e09e56893f48bc2"
+SRC_URI[md5sum] = "3674ca2d40388b1175e25b6f5a3a82ad"
+SRC_URI[sha256sum] = "60198cbb34066b9b5c1613d15c0479f6cd25f4aef42f7ec515cd1cc13a77fede"
+require libgit2-release.inc
diff --git a/meta-sota/recipes-support/libssh2/libssh2_%.bbappend b/meta-sota/recipes-support/libssh2/libssh2_%.bbappend
new file mode 100644
index 0000000..ce4807e
--- /dev/null
+++ b/meta-sota/recipes-support/libssh2/libssh2_%.bbappend
@@ -0,0 +1,2 @@
+# meta-oe/recipes-support/libssh2
+BBCLASSEXTEND = "native"
diff --git a/meta-sota/recipes-support/lshw/files/cross-compile.patch b/meta-sota/recipes-support/lshw/files/cross-compile.patch
new file mode 100644
index 0000000..221b7e5
--- /dev/null
+++ b/meta-sota/recipes-support/lshw/files/cross-compile.patch
@@ -0,0 +1,39 @@
+---
+ src/Makefile | 2 +-
+ src/core/Makefile | 2 +-
+ src/gui/Makefile | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -18,7 +18,7 @@ export MANDIR
+ export DATADIR
+ export SQLITE
+
+-CXX?=c++
++CXX?=$(CROSS_COMPILE)c++
+ INCLUDES=-I./core/
+ DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
+ CXXFLAGS=-g -Wall -g $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
+--- a/src/core/Makefile
++++ b/src/core/Makefile
+@@ -1,6 +1,6 @@
+ PACKAGENAME?=lshw
+
+-CXX=c++
++CXX?=$(CROSS_COMPILE)c++
+ INCLUDES=
+ DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
+ CXXFLAGS?=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
+--- a/src/gui/Makefile
++++ b/src/gui/Makefile
+@@ -1,7 +1,7 @@
+ PACKAGENAME?=lshw
+
+-CXX?=c++
+-CC?=cc
++CXX?=$(CROSS_COMPILE)c++
++CC?=$(CROSS_COMPILE)cc
+ STRIP?=strip
+ OBJCOPY?=objcopy
+
diff --git a/meta-sota/recipes-support/lshw/lshw_02.16.bb b/meta-sota/recipes-support/lshw/lshw_02.16.bb
new file mode 100644
index 0000000..3a61dab
--- /dev/null
+++ b/meta-sota/recipes-support/lshw/lshw_02.16.bb
@@ -0,0 +1,36 @@
+# From meta-linaro
+# http://git.linaro.org/openembedded/meta-linaro.git
+
+DESCRIPTION = "A small tool to provide detailed information on the hardware \
+configuration of the machine. It can report exact memory configuration, \
+firmware version, mainboard configuration, CPU version and speed, cache \
+configuration, bus speed, etc. on DMI-capable or EFI systems."
+SUMMARY = "Hardware lister"
+HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
+SECTION = "console/tools"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+DEPENDS = "pciutils \
+ usbutils"
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+
+PR="r1"
+
+SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
+ file://cross-compile.patch"
+
+SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d"
+SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb"
+
+S="${WORKDIR}/lshw-B.${PV}"
+
+do_compile() {
+ # build core only - don't ship gui
+ oe_runmake -C src core
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ # data files provided by dependencies
+ rm -rf ${D}/usr/share/lshw
+}