summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb2
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc2
-rw-r--r--meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd/allows-upgrade.patch91
-rw-r--r--meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb (renamed from meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.48.bb)12
-rw-r--r--meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bbappend (renamed from meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.48.bbappend)0
-rw-r--r--meta-sota/classes/image_types_ota.bbclass1
-rw-r--r--meta-sota/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch141
-rw-r--r--meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb3
-rw-r--r--templates/feature/agl-sota/50_local.conf.inc2
9 files changed, 231 insertions, 23 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 3b70fec..5c47e3a 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -16,7 +16,7 @@ SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
"
-SRCREV = "b0d9ff9157f188a32d46c7a583b5b2e35ca26343"
+SRCREV = "dc011f99aed9407c8319b1b70a81f56ad2f02bc8"
S = "${WORKDIR}/git"
inherit cmake pkgconfig
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index e89f616..141ae46 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -14,7 +14,7 @@ SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
"
-SRCREV = "373b10369b60cf2bfa54388197c05a09ef32de41"
+SRCREV = "628dc10767d95436538391534dc3c95f45fe9a3a"
S = "${WORKDIR}/git"
diff --git a/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd/allows-upgrade.patch b/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd/allows-upgrade.patch
index b35d970..19601a5 100644
--- a/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd/allows-upgrade.patch
+++ b/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd/allows-upgrade.patch
@@ -1,14 +1,81 @@
diff -Naur a/src/microhttpd/connection.c b/src/microhttpd/connection.c
---- a/src/microhttpd/connection.c 2016-04-20 11:35:50.259534537 +0000
-+++ b/src/microhttpd/connection.c 2016-04-20 11:29:46.291569583 +0000
-@@ -733,8 +733,7 @@
- {
- if (NULL == end)
- return MHD_YES;
-- if ( (MHD_str_equal_caseless_ (end, "close")) ||
-- (MHD_str_equal_caseless_ (end, "upgrade")) )
+--- a/src/microhttpd/connection.c 2016-04-08 21:02:26.000000000 +0200
++++ b/src/microhttpd/connection.c 2016-08-29 22:41:53.790560238 +0200
+@@ -708,6 +708,8 @@
+ * "keep-alive", we proceed to use the default for the respective HTTP
+ * version (which is conservative for HTTP 1.0, but might be a bit
+ * optimistic for HTTP 1.1).
++ * In the case of Upgrade, the header Connection should not be set
++ * to keep-alive.
+ *
+ * @param connection the connection to check for keepalive
+ * @return #MHD_YES if (based on the request), a keepalive is
+@@ -750,6 +752,59 @@
+
+
+ /**
++ * Should we try to keep the given connection alive? We can use the
++ * TCP stream for a second request if the connection is HTTP 1.1 and
++ * the "Connection" header either does not exist or is not set to
++ * "close", or if the connection is HTTP 1.0 and the "Connection"
++ * header is explicitly set to "keep-alive". If no HTTP version is
++ * specified (or if it is not 1.0 or 1.1), we definitively close the
++ * connection. If the "Connection" header is not exactly "close" or
++ * "keep-alive", we proceed to use the default for the respective HTTP
++ * version (which is conservative for HTTP 1.0, but might be a bit
++ * optimistic for HTTP 1.1).
++ * In the case of Upgrade, the connection should be kept alive even if
++ * the header Connection is not keep-alive.
++ *
++ * @param connection the connection to check for keepalive
++ * @return #MHD_YES if (based on the request), a keepalive is
++ * legal
++ */
++static int
++should_keepalive (struct MHD_Connection *connection)
++{
++ const char *end;
++
++ if (NULL == connection->version)
++ return MHD_NO;
++ if ( (NULL != connection->response) &&
++ (0 != (connection->response->flags & MHD_RF_HTTP_VERSION_1_0_ONLY) ) )
++ return MHD_NO;
++ end = MHD_lookup_connection_value (connection,
++ MHD_HEADER_KIND,
++ MHD_HTTP_HEADER_CONNECTION);
++ if (MHD_str_equal_caseless_(connection->version,
++ MHD_HTTP_VERSION_1_1))
++ {
++ if (NULL == end)
++ return MHD_YES;
+ if ( (MHD_str_equal_caseless_ (end, "close")) )
- return MHD_NO;
- return MHD_YES;
- }
-
++ return MHD_NO;
++ return MHD_YES;
++ }
++ if (MHD_str_equal_caseless_(connection->version,
++ MHD_HTTP_VERSION_1_0))
++ {
++ if (NULL == end)
++ return MHD_NO;
++ if (MHD_str_equal_caseless_(end, "Keep-Alive"))
++ return MHD_YES;
++ return MHD_NO;
++ }
++ return MHD_NO;
++}
++
++
++/**
+ * Produce HTTP "Date:" header.
+ *
+ * @param date where to write the header, with
+@@ -2795,7 +2850,7 @@
+ }
+ if (((MHD_YES == connection->read_closed) &&
+ (0 == connection->read_buffer_offset)) ||
+- (MHD_NO == keepalive_possible (connection)))
++ (MHD_NO == should_keepalive (connection)))
+ {
+ /* have to close for some reason */
+ MHD_connection_close_ (connection,
diff --git a/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.48.bb b/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb
index 892009e..9abb200 100644
--- a/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.48.bb
+++ b/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb
@@ -6,22 +6,20 @@ SECTION = "net"
DEPENDS = "libgcrypt gnutls file"
SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
-SRC_URI[md5sum] = "9c298c890088a91fe0d7ac3fec9d0097"
-SRC_URI[sha256sum] = "87667e158f2bf8c691a002e256ffe30885d4121a9ee4143af0320c47cdf8a2a4"
+SRC_URI[md5sum] = "3209aa2ac6199b874a6325342b86edbc"
+SRC_URI[sha256sum] = "9407d8252548ab97ace3276e0032f073820073c0599d43baff832902a8dab11c"
-inherit autotools lib_package
+inherit autotools lib_package pkgconfig
-# disable spdy, because it depends on openssl
EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
PACKAGECONFIG ?= "curl"
PACKAGECONFIG_append_class-target = "\
- ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
"
PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
do_compile_append() {
- sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
+ sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
}
-
diff --git a/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.48.bbappend b/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bbappend
index c26b811..c26b811 100644
--- a/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.48.bbappend
+++ b/meta-app-framework/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bbappend
diff --git a/meta-sota/classes/image_types_ota.bbclass b/meta-sota/classes/image_types_ota.bbclass
index 9820724..cc526b6 100644
--- a/meta-sota/classes/image_types_ota.bbclass
+++ b/meta-sota/classes/image_types_ota.bbclass
@@ -12,6 +12,7 @@ export BOOTFS_EXTRA_SIZE
do_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \
parted-native:do_populate_sysroot \
virtual/kernel:do_deploy \
+ virtual/bootloader:do_deploy \
${INITRD_IMAGE}:do_rootfs \
${PN}:do_rootfs"
diff --git a/meta-sota/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch b/meta-sota/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
new file mode 100644
index 0000000..83e223f
--- /dev/null
+++ b/meta-sota/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
@@ -0,0 +1,141 @@
+From d5bea58bf85522a289194d59dfab00207ffdfb4f Mon Sep 17 00:00:00 2001
+From: Anton Gerasimov <anton@advancedtelematic.com>
+Date: Fri, 26 Aug 2016 13:51:30 +0200
+Subject: [PATCH 2/2] Replace wraps with built-in code to remove dependency on
+ multilib
+
+---
+ arch/x86/config.mk | 3 --
+ arch/x86/lib/gcc.c | 97 +++++++++++++++++++++++++++++++++++++++++++++++-------
+ 2 files changed, 86 insertions(+), 14 deletions(-)
+
+diff --git a/arch/x86/config.mk b/arch/x86/config.mk
+index d7addd8..892e0fc 100644
+--- a/arch/x86/config.mk
++++ b/arch/x86/config.mk
+@@ -21,9 +21,6 @@ PLATFORM_RELFLAGS += -ffunction-sections -fvisibility=hidden
+
+ PLATFORM_LDFLAGS += -Bsymbolic -Bsymbolic-functions -m elf_i386
+
+-LDFLAGS_FINAL += --wrap=__divdi3 --wrap=__udivdi3
+-LDFLAGS_FINAL += --wrap=__moddi3 --wrap=__umoddi3
+-
+ # This is used in the top-level Makefile which does not include
+ # PLATFORM_LDFLAGS
+ LDFLAGS_EFI_PAYLOAD := -Bsymbolic -Bsymbolic-functions -shared --no-undefined
+diff --git a/arch/x86/lib/gcc.c b/arch/x86/lib/gcc.c
+index 3c70d79..6b47785 100644
+--- a/arch/x86/lib/gcc.c
++++ b/arch/x86/lib/gcc.c
+@@ -8,22 +8,97 @@
+
+ #ifdef __GNUC__
+
++#include <stdint.h>
++#include <stddef.h>
+ /*
+ * GCC's libgcc handling is quite broken. While the libgcc functions
+ * are always regparm(0) the code that calls them uses whatever the
+ * compiler call specifies. Therefore we need a wrapper around those
+ * functions. See gcc bug PR41055 for more information.
+ */
+-#define WRAP_LIBGCC_CALL(type, name) \
+- type __normal_##name(type a, type b) __attribute__((regparm(0))); \
+- type __wrap_##name(type a, type b); \
+- type __attribute__((no_instrument_function)) \
+- __wrap_##name(type a, type b) \
+- { return __normal_##name(a, b); }
+-
+-WRAP_LIBGCC_CALL(long long, __divdi3)
+-WRAP_LIBGCC_CALL(unsigned long long, __udivdi3)
+-WRAP_LIBGCC_CALL(long long, __moddi3)
+-WRAP_LIBGCC_CALL(unsigned long long, __umoddi3)
++uint64_t __udivmoddi4 ( uint64_t num,
++ uint64_t den,
++ uint64_t *rem_p )
++{
++ uint64_t quot = 0, qbit = 1;
++
++ if ( den == 0 ) {
++ return 1/((unsigned)den); /* Intentional divide by zero, without
++ triggering a compiler warning which
++ would abort the build */
++ }
++
++ /* Left-justify denominator and count shift */
++ while ( (int64_t)den >= 0 ) {
++ den <<= 1;
++ qbit <<= 1;
++ }
++
++ while ( qbit ) {
++ if ( den <= num ) {
++ num -= den;
++ quot += qbit;
++ }
++ den >>= 1;
++ qbit >>= 1;
++ }
++
++ if ( rem_p )
++ *rem_p = num;
++
++ return quot;
++}
++
++uint64_t __udivdi3( uint64_t num, uint64_t den )
++{
++ return __udivmoddi4(num, den, NULL);
++}
++
++uint64_t __umoddi3 ( uint64_t num, uint64_t den )
++{
++ uint64_t v;
++
++ (void) __udivmoddi4(num, den, &v);
++ return v;
++}
++
++int64_t __divmoddi4 ( int64_t num,
++ int64_t den,
++ int64_t* rem_p )
++{
++ int minus = 0;
++ int64_t v;
++
++ if ( num < 0 ) {
++ num = -num;
++ minus = 1;
++ }
++ if ( den < 0 ) {
++ den = -den;
++ minus ^= 1;
++ }
++
++ v = __udivmoddi4(num, den, (uint64_t *)rem_p);
++ if ( minus ) {
++ v = -v;
++ if ( rem_p )
++ *rem_p = -(*rem_p);
++ }
++
++ return v;
++}
++
++int64_t __moddi3 (int64_t num, int64_t den)
++{
++ int64_t v;
++
++ (void) __divmoddi4(num, den, &v);
++ return v;
++}
++
++int64_t __divdi3(int64_t num, int64_t den)
++{
++ return __divmoddi4(num, den, NULL);
++}
+
+ #endif
+--
+2.9.2
+
diff --git a/meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb b/meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb
index 8f0b20a..7d440ef 100644
--- a/meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb
+++ b/meta-sota/recipes-bsp/u-boot/u-boot-ota_2016.07.bb
@@ -9,7 +9,8 @@ LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
# repo during parse
SRCREV = "25922d42f8e9e7ae503ae55a972ba1404e5b6a8c"
-SRC_URI += "file://0001-Set-up-environment-for-OSTree-integration.patch"
+SRC_URI += "file://0001-Set-up-environment-for-OSTree-integration.patch \
+ file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch"
PV = "v2016.07+git${SRCPV}"
diff --git a/templates/feature/agl-sota/50_local.conf.inc b/templates/feature/agl-sota/50_local.conf.inc
index a27d7af..d2bab53 100644
--- a/templates/feature/agl-sota/50_local.conf.inc
+++ b/templates/feature/agl-sota/50_local.conf.inc
@@ -5,7 +5,7 @@ IMAGE_CLASSES += "image_types_ota"
IMAGE_FSTYPES += "otaimg"
UBOOT_MACHINE_qemux86 = "qemu-x86_defconfig"
-UBOOT_MACHINE_qemux86_64 = "qemu-x86_defconfig"
+UBOOT_MACHINE_qemux86-64 = "qemu-x86_defconfig"
PREFERRED_PROVIDER_virtual/bootloader_qemux86 ?= "u-boot-ota"
PREFERRED_PROVIDER_virtual/bootloader_qemux86-64 ?= "u-boot-ota"