summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime1
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb2
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux-%.bbappend3
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux/audit.cfg2
-rw-r--r--templates/feature/agl-demo/50_bblayers.conf.inc1
-rw-r--r--templates/feature/agl-demo/50_local.conf.inc3
6 files changed, 11 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
index ca712e1..0b86044 100755
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
+++ b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
@@ -1,2 +1,3 @@
#!/bin/sh
+export QT_WAYLAND_SHELL_INTEGRATION="ivi-shell"
exec /usr/bin/qt5/qmlscene "$1" /usr/bin/web-runtime-webkit.qml
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
index 9df4dff..fa14987 100644
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
+++ b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
@@ -7,7 +7,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
SRC_URI = "\
- file://web-runtime;md5sum=00cdb6980e03cf8c8f7d60dd978c61d7 \
+ file://web-runtime;md5sum=6114c0bdd20290912a423fa01beb50f0 \
file://web-runtime.qml;md5sum=5d6a379e9b7e5654319e5ba638824a58 \
file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
"
diff --git a/meta-app-framework/recipes-kernel/linux/linux-%.bbappend b/meta-app-framework/recipes-kernel/linux/linux-%.bbappend
new file mode 100644
index 0000000..02595ef
--- /dev/null
+++ b/meta-app-framework/recipes-kernel/linux/linux-%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+SRC_URI_append_smack = " file://audit.cfg"
+
diff --git a/meta-app-framework/recipes-kernel/linux/linux/audit.cfg b/meta-app-framework/recipes-kernel/linux/linux/audit.cfg
new file mode 100644
index 0000000..214dbe3
--- /dev/null
+++ b/meta-app-framework/recipes-kernel/linux/linux/audit.cfg
@@ -0,0 +1,2 @@
+CONFIG_AUDIT=y
+CONFIG_AUDITSYSCALL=y
diff --git a/templates/feature/agl-demo/50_bblayers.conf.inc b/templates/feature/agl-demo/50_bblayers.conf.inc
index 07c20d3..7f04f69 100644
--- a/templates/feature/agl-demo/50_bblayers.conf.inc
+++ b/templates/feature/agl-demo/50_bblayers.conf.inc
@@ -7,6 +7,7 @@ BBLAYERS =+ " \
# These are the dependencies of the AGL DEMO Layer
#-------------------------------------------------
BBLAYERS =+ " \
+ ${METADIR}/meta-oic \
${METADIR}/meta-qt5 \
"
diff --git a/templates/feature/agl-demo/50_local.conf.inc b/templates/feature/agl-demo/50_local.conf.inc
index 6d1ce9f..9116f40 100644
--- a/templates/feature/agl-demo/50_local.conf.inc
+++ b/templates/feature/agl-demo/50_local.conf.inc
@@ -9,3 +9,6 @@ IMAGE_INSTALL_append = " qtwebkit qtwebkit-examples-examples"
# add support for websocket in Qt and QML
IMAGE_INSTALL_append = " qtwebsockets qtwebsockets-qmlplugins"
+
+IMAGE_INSTALL_append = " iotivity-resource-samples "
+IMAGE_INSTALL_append = " screen "