summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-sota/classes/image_types_ostree.bbclass2
-rw-r--r--meta-sota/classes/sdcard_image-dra7xx-evm-ota.bbclass3
-rw-r--r--meta-sota/classes/sdcard_image-porter-ota.bbclass3
-rw-r--r--meta-sota/classes/sdcard_image-rpi-ota.bbclass9
-rw-r--r--meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch40
-rw-r--r--meta-sota/recipes-devtools/pseudo/files/fallback-group2
-rw-r--r--meta-sota/recipes-devtools/pseudo/files/fallback-passwd1
-rw-r--r--meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb20
-rw-r--r--meta-sota/recipes-support/libgsystem/libgsystem_git.bb2
9 files changed, 15 insertions, 67 deletions
diff --git a/meta-sota/classes/image_types_ostree.bbclass b/meta-sota/classes/image_types_ostree.bbclass
index 32ea98f..04aeae8 100644
--- a/meta-sota/classes/image_types_ostree.bbclass
+++ b/meta-sota/classes/image_types_ostree.bbclass
@@ -4,7 +4,7 @@ inherit image
IMAGE_DEPENDS_ostree = "ostree-native:do_populate_sysroot \
virtual/kernel:do_deploy \
- ${OSTREE_INITRAMFS_IMAGE}:do_image_ext4"
+ ${OSTREE_INITRAMFS_IMAGE}:do_image_complete"
export OSTREE_REPO
export OSTREE_BRANCHNAME
diff --git a/meta-sota/classes/sdcard_image-dra7xx-evm-ota.bbclass b/meta-sota/classes/sdcard_image-dra7xx-evm-ota.bbclass
index f023649..179ed10 100644
--- a/meta-sota/classes/sdcard_image-dra7xx-evm-ota.bbclass
+++ b/meta-sota/classes/sdcard_image-dra7xx-evm-ota.bbclass
@@ -68,5 +68,8 @@ IMAGE_CMD_dra7xx-evm-sdimg-ota () {
xz -k "${SDIMG_OTA}"
;;
esac
+
+ rm -f ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.dra7xx-evm-sdimg-ota
+ ln -s ${IMAGE_NAME}.rootfs.dra7xx-evm-sdimg-ota ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.dra7xx-evm-sdimg-ota
}
diff --git a/meta-sota/classes/sdcard_image-porter-ota.bbclass b/meta-sota/classes/sdcard_image-porter-ota.bbclass
index 1b1de79..a9619dc 100644
--- a/meta-sota/classes/sdcard_image-porter-ota.bbclass
+++ b/meta-sota/classes/sdcard_image-porter-ota.bbclass
@@ -71,5 +71,8 @@ IMAGE_CMD_porter-sdimg-ota () {
xz -k "${SDIMG_OTA}"
;;
esac
+
+ rm -f ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.porter-sdimg-ota
+ ln -s ${IMAGE_NAME}.rootfs.porter-sdimg-ota ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.porter-sdimg-ota
}
diff --git a/meta-sota/classes/sdcard_image-rpi-ota.bbclass b/meta-sota/classes/sdcard_image-rpi-ota.bbclass
index 2fa03c4..deea8d1 100644
--- a/meta-sota/classes/sdcard_image-rpi-ota.bbclass
+++ b/meta-sota/classes/sdcard_image-rpi-ota.bbclass
@@ -125,8 +125,10 @@ IMAGE_CMD_rpi-sdimg-ota () {
# Copy device tree overlays to dedicated folder
mmd -i ${WORKDIR}/boot.img overlays
for DTB in ${DT_OVERLAYS}; do
- DTB_BASE_NAME=`basename ${DTB} .dtb`
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${DTB_BASE_NAME}.dtb ::overlays/${DTB_BASE_NAME}.dtbo
+ DTB_EXT=${DTB##*.}
+ DTB_BASE_NAME=`basename ${DTB} ."${DTB_EXT}"`
+
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${DTB_BASE_NAME}.${DTB_EXT} ::overlays/${DTB_BASE_NAME}.${DTB_EXT}
done
fi
@@ -174,6 +176,9 @@ IMAGE_CMD_rpi-sdimg-ota () {
xz -k "${SDIMG_OTA}"
;;
esac
+
+ rm -f ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.rpi-sdimg-ota
+ ln -s ${IMAGE_NAME}.rootfs.rpi-sdimg-ota ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.rpi-sdimg-ota
}
ROOTFS_POSTPROCESS_COMMAND += " rpi_generate_sysctl_config ; "
diff --git a/meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch b/meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch
deleted file mode 100644
index 3da2ad7..0000000
--- a/meta-sota/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 41bb6c818a7ec9eeb33b60302c55c9c5ee393c5f Mon Sep 17 00:00:00 2001
-From: Anton Gerasimov <anton@advancedtelematic.com>
-Date: Fri, 30 Sep 2016 17:12:19 +0200
-Subject: [PATCH 1/1] Add check for existence of old file to renameat
-
----
- ports/unix/guts/renameat.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/ports/unix/guts/renameat.c b/ports/unix/guts/renameat.c
-index ade0509..d5e36fa 100644
---- a/ports/unix/guts/renameat.c
-+++ b/ports/unix/guts/renameat.c
-@@ -11,6 +11,7 @@
- int oldrc, newrc;
- int save_errno;
- int old_db_entry = 0;
-+ int may_unlinked = 0;
-
- pseudo_debug(PDBGF_FILE, "renameat: %d,%s->%d,%s\n",
- olddirfd, oldpath ? oldpath : "<nil>",
-@@ -44,10 +45,14 @@
- /* as with unlink, we have to mark that the file may get deleted */
- msg = pseudo_client_op(OP_MAY_UNLINK, 0, -1, newdirfd, newpath, newrc ? NULL : &newbuf);
- if (msg && msg->result == RESULT_SUCCEED)
-+ may_unlinked = 1;
-+ msg = pseudo_client_op(OP_STAT, 0, -1, olddirfd, oldpath, oldrc ? NULL : &oldbuf);
-+ if (msg && msg->result == RESULT_SUCCEED)
- old_db_entry = 1;
-+
- rc = real_renameat(olddirfd, oldpath, newdirfd, newpath);
- save_errno = errno;
-- if (old_db_entry) {
-+ if (may_unlinked) {
- if (rc == -1) {
- /* since we failed, that wasn't really unlinked -- put
- * it back.
---
-2.9.3
-
diff --git a/meta-sota/recipes-devtools/pseudo/files/fallback-group b/meta-sota/recipes-devtools/pseudo/files/fallback-group
deleted file mode 100644
index 81bf732..0000000
--- a/meta-sota/recipes-devtools/pseudo/files/fallback-group
+++ /dev/null
@@ -1,2 +0,0 @@
-root:*:0:
-mail:*:8:
diff --git a/meta-sota/recipes-devtools/pseudo/files/fallback-passwd b/meta-sota/recipes-devtools/pseudo/files/fallback-passwd
deleted file mode 100644
index c1458dc..0000000
--- a/meta-sota/recipes-devtools/pseudo/files/fallback-passwd
+++ /dev/null
@@ -1 +0,0 @@
-root::0:0:root:/home/root:/bin/sh
diff --git a/meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb b/meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb
deleted file mode 100644
index 211439e..0000000
--- a/meta-sota/recipes-devtools/pseudo/pseudo_1.8.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-require recipes-devtools/pseudo/pseudo.inc
-
-SRC_URI = " \
- http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \
- file://fallback-passwd \
- file://fallback-group \
- file://0001-Add-check-for-existence-of-old-file-to-renameat.patch \
-"
-
-SRC_URI[md5sum] = "ee38e4fb62ff88ad067b1a5a3825bac7"
-SRC_URI[sha256sum] = "dac4ad2d21228053151121320f629d41dd5c0c87695ac4e7aea286c414192ab5"
-
-PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
-
-do_install_append_class-native () {
- install -d ${D}${sysconfdir}
- # The fallback files should never be modified
- install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
- install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
-}
diff --git a/meta-sota/recipes-support/libgsystem/libgsystem_git.bb b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
index 92ac386..2b93191 100644
--- a/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
+++ b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
@@ -9,7 +9,7 @@ S = "${WORKDIR}/git"
inherit autotools-brokensep gobject-introspection
-DEPENDS += "attr glib-2.0 pkgconfig libcap gtk-doc-native"
+DEPENDS += "attr glib-2.0 pkgconfig libcap gtk-doc-native gpgme"
RDEPENDS_${PN} = "xz systemd"
RDEPENDS_${PN}_remove_class-native = "systemd-native"