summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-sota/recipes-core/images/initramfs-ostree-image.bb4
-rw-r--r--templates/feature/agl-sota/50_local.conf.inc2
2 files changed, 5 insertions, 1 deletions
diff --git a/meta-sota/recipes-core/images/initramfs-ostree-image.bb b/meta-sota/recipes-core/images/initramfs-ostree-image.bb
index 9e47086..e4123d4 100644
--- a/meta-sota/recipes-core/images/initramfs-ostree-image.bb
+++ b/meta-sota/recipes-core/images/initramfs-ostree-image.bb
@@ -13,7 +13,9 @@ IMAGE_LINGUAS = ""
LICENSE = "MIT"
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+# was ${INITRAMFS_FSTYPES} which defaults to cpio.gz
+# due to xattr, we need ext3/4
+IMAGE_FSTYPES = "ext4.gz"
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"
diff --git a/templates/feature/agl-sota/50_local.conf.inc b/templates/feature/agl-sota/50_local.conf.inc
index 41c201e..05cf3cf 100644
--- a/templates/feature/agl-sota/50_local.conf.inc
+++ b/templates/feature/agl-sota/50_local.conf.inc
@@ -11,6 +11,8 @@ UBOOT_MACHINE_qemux86-64 = "qemu-x86_defconfig"
PREFERRED_PROVIDER_virtual/bootloader_qemux86 ?= "u-boot-ota"
PREFERRED_PROVIDER_virtual/bootloader_qemux86-64 ?= "u-boot-ota"
+PREFERRED_PROVIDER_virtual/bootloader_raspberrypi3 ?= "u-boot-ota"
+PREFERRED_PROVIDER_virtual/bootloader_raspberrypi2 ?= "u-boot-ota"
# Please redefine OSTREE_REPO in order to have a persistent OSTree repo
OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo"