summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb')
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
new file mode 100644
index 0000000..c5b4b53
--- /dev/null
+++ b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL Application Framework core packages"
+DESCRIPTION = "The set of packages required by the AGL Application Framework"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-app-framework \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ af-binder \
+ af-main \
+ web-runtime \
+ "