summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb')
-rw-r--r--meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
index 9f5f0ca..82d0410 100644
--- a/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
+++ b/meta-sota/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
@@ -7,7 +7,8 @@ DEPENDS = "u-boot-mkimage-native"
COMPATIBLE_MACHINE = "raspberrypi"
SRC_URI = "file://boot.scr \
- file://uEnv.txt"
+ file://uEnv.txt \
+ file://uEnv.cma.txt"
S = "${WORKDIR}"
@@ -17,7 +18,11 @@ do_deploy() {
install -d ${DEPLOYDIR}/bcm2835-bootfiles
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
- install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
+ if [ "${ENABLE_CMA}" = "1" ]; then
+ install -m 0755 ${S}/uEnv.cma.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
+ else
+ install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
+ fi
}
addtask deploy before do_package after do_install