summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-bsp/u-boot')
-rw-r--r--meta-sota/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch36
-rw-r--r--meta-sota/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb19
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-sota/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch b/meta-sota/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch
new file mode 100644
index 0000000..c33d40c
--- /dev/null
+++ b/meta-sota/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch
@@ -0,0 +1,36 @@
+From 2b4d519bef51d9bfb646588aa5198f71022a867b Mon Sep 17 00:00:00 2001
+From: Anton Gerasimov <anton@advancedtelematic.com>
+Date: Mon, 15 Aug 2016 15:54:20 +0200
+Subject: [PATCH] Set up environment for OSTree integration
+
+---
+ include/configs/qemu-x86.h | 15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
+
+diff --git a/include/configs/qemu-x86.h b/include/configs/qemu-x86.h
+index 476d37d..f49e2a5 100644
+--- a/include/configs/qemu-x86.h
++++ b/include/configs/qemu-x86.h
+@@ -56,4 +56,19 @@
+ #undef CONFIG_ENV_IS_IN_SPI_FLASH
+ #define CONFIG_ENV_IS_NOWHERE
+
++#undef CONFIG_BOOTARGS
++#define CONFIG_BOOTARGS "root=/dev/hda2 console=ttyS0"
++
++#undef CONFIG_BOOTCOMMAND
++#define CONFIG_BOOTCOMMAND "run loadenv;" \
++ "ext2load ide 0:1 $loadaddr $kernel_image;" \
++ "ext2load ide 0:1 $ramdiskaddr $ramdisk_image;" \
++ "zboot $loadaddr - $ramdiskaddr $filesize"
++
++#undef CONFIG_EXTRA_ENV_SETTINGS
++#define CONFIG_EXTRA_ENV_SETTINGS "kernel_image=/bzImage\0" \
++ "ramdisk_image=/initrd\0" \
++ "ramdiskaddr=0x4000000\0" \
++ "loadenv=if ext2ls ide 0:1 /loader.0/uEnv.txt; then ext2load ide 0:1 $loadaddr uEnv.txt; env import -t $loadaddr $filesize; fi;"
++
+ #endif /* __CONFIG_H */
+--
+2.8.3
+
diff --git a/meta-sota/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb b/meta-sota/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb
new file mode 100644
index 0000000..7e3c67f
--- /dev/null
+++ b/meta-sota/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb
@@ -0,0 +1,19 @@
+include recipes-bsp/u-boot/u-boot.inc
+DEPENDS += "dtc-native"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+
+# This revision corresponds to the tag "v2016.07"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "25922d42f8e9e7ae503ae55a972ba1404e5b6a8c"
+
+SRC_URI += "file://0001-Set-up-environment-for-OSTree-integration.patch"
+
+PV = "v2016.07+git${SRCPV}"
+
+EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
+
+UBOOT_SUFFIX = "rom"
+