summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-core/images/initramfs-ostree-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-core/images/initramfs-ostree-image.bb')
-rw-r--r--meta-sota/recipes-core/images/initramfs-ostree-image.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-sota/recipes-core/images/initramfs-ostree-image.bb b/meta-sota/recipes-core/images/initramfs-ostree-image.bb
new file mode 100644
index 0000000..71aa631
--- /dev/null
+++ b/meta-sota/recipes-core/images/initramfs-ostree-image.bb
@@ -0,0 +1,23 @@
+# Netboot initramfs image.
+DESCRIPTION = "OSTree initramfs image"
+
+PACKAGE_INSTALL = "ostree ostree-initramfs systemd-initramfs busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+SYSTEMD_DEFAULT_TARGET = "initrd.target"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "initramfs-ostree-image"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
+
+