summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-sota/libgsystem/libgsystem_git.bb')
-rw-r--r--meta-sota/recipes-sota/libgsystem/libgsystem_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb b/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
index f35819d..fe1e552 100644
--- a/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
+++ b/meta-sota/recipes-sota/libgsystem/libgsystem_git.bb
@@ -15,7 +15,23 @@ inherit autotools-brokensep
BBCLASSEXTEND += "native"
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
do_configure() {
NOCONFIGURE=true ./autogen.sh
oe_runconf
}
+
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
+FILES_${PN} += " \
+ ${datadir} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/GSystem-1.0.gir \
+ ${libdir}/girepository-1.0/ \
+ ${libdir}/girepository-1.0/GSystem-1.0.typelib \
+"