summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-sota/ostree/ostree_git.bb')
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb32
1 files changed, 21 insertions, 11 deletions
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
index 659ee83..0e53d25 100644
--- a/meta-sota/recipes-sota/ostree/ostree_git.bb
+++ b/meta-sota/recipes-sota/ostree/ostree_git.bb
@@ -4,24 +4,35 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
inherit autotools-brokensep pkgconfig systemd
+INHERIT_remove_class-native = "systemd"
+
SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
SRCREV="v2016.9"
S = "${WORKDIR}/git"
+BBCLASSEXTEND = "native"
+
DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd"
+DEPENDS_remove_class-native = "systemd-native"
+
+RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz"
+RDEPENDS_${PN}_remove_class-native = "python-native"
-RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma"
+EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
+
+SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
+SYSTEMD_REQUIRED_class-native = ""
+
+SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
+SYSTEMD_SERVICE_${PN}_class-native = ""
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
+PACKAGECONFIG_class-native = ""
PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
-EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
-
FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
-BBCLASSEXTEND = "native"
-
export STAGING_INCDIR
export STAGING_LIBDIR
@@ -35,19 +46,18 @@ do_compile_prepend() {
export HOST_SYS="${HOST_SYS}"
}
+export SYSTEMD_REQUIRED
+
do_install_append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ if [ -n ${SYSTEMD_REQUIRED} ]; then
install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
fi
}
-SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
FILES_${PN} += " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \
+ ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
${datadir}/gir-1.0 \
${datadir}/gir-1.0/OSTree-1.0.gir \
- ${libdir}/dracut/ \
- ${libdir}/girepository-1.0 \
- ${libdir}/girepository-1.0/OSTree-1.0.typelib \
"
+