summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-sota')
-rw-r--r--meta-sota/recipes-sota/ostree-initrd/files/init.sh84
-rw-r--r--meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb19
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb83
-rw-r--r--meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb201
-rw-r--r--meta-sota/recipes-sota/sota-tools/sota-tools_git.bb24
5 files changed, 0 insertions, 411 deletions
diff --git a/meta-sota/recipes-sota/ostree-initrd/files/init.sh b/meta-sota/recipes-sota/ostree-initrd/files/init.sh
deleted file mode 100644
index 806a7b1..0000000
--- a/meta-sota/recipes-sota/ostree-initrd/files/init.sh
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/sh
-
-# global variables
-
-SMACK=n
-DEBUG=n
-
-# -------------------------------------------
-
-log_info() { echo "$0[$$]: $@" >&2; }
-log_error() { echo "$0[$$]: ERROR $@" >&2; }
-
-do_mount_fs() {
- log_info "mounting FS: $@"
- [[ -e /proc/filesystems ]] && { grep -q "$1" /proc/filesystems || { log_error "Unknown filesystem"; return 1; } }
- [[ -d "$2" ]] || mkdir -p "$2"
- [[ -e /proc/mounts ]] && { grep -q -e "^$1 $2 $1" /proc/mounts && { log_info "$2 ($1) already mounted"; return 0; } }
- mount -t "$1" "$1" "$2"
-}
-
-bail_out() {
- log_error "$@"
- log_info "Rebooting..."
- #exec reboot -f
- exec sh
-}
-
-get_ostree_sysroot() {
- for opt in `cat /proc/cmdline`; do
- arg=`echo $opt | cut -d'=' -f1`
- if [ $arg == "ostree_root" ]; then
- echo $opt | cut -d'=' -f2
- return
- fi
- done
-}
-
-export PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/lib/ostree
-
-log_info "starting initrd script"
-
-do_mount_fs proc /proc
-do_mount_fs sysfs /sys
-do_mount_fs devtmpfs /dev
-do_mount_fs devpts /dev/pts
-do_mount_fs tmpfs /dev/shm
-do_mount_fs tmpfs /tmp
-do_mount_fs tmpfs /run
-
-# check if smack is active (and if so, mount smackfs)
-grep -q smackfs /proc/filesystems && {
- SMACK=y
-
- do_mount_fs smackfs /sys/fs/smackfs
-
- # adjust current label and network label
- echo System >/proc/self/attr/current
- echo System >/sys/fs/smackfs/ambient
-}
-
-mkdir -p /sysroot
-ostree_sysroot=$(get_ostree_sysroot)
-
-mount $ostree_sysroot /sysroot || bail_out "Unable to mount $ostree_sysroot as physical sysroot"
-ostree-prepare-root /sysroot
-
-# move mounted devices to new root
-cd /sysroot
-for x in dev proc; do
- log_info "Moving /$x to new rootfs"
- mount -o move /$x $x
-done
-
-# switch to new rootfs
-log_info "Switching to new rootfs"
-mkdir -p run/initramfs
-
-pivot_root . run/initramfs || bail_out "pivot_root failed."
-
-log_info "Launching target init"
-
-exec chroot . sh -c 'umount /run/initramfs; exec /sbin/init' \
- <dev/console >dev/console 2>&1
-
diff --git a/meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb b/meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb
deleted file mode 100644
index 5c85bee..0000000
--- a/meta-sota/recipes-sota/ostree-initrd/ostree-initrd.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Extremely basic live image init script"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-SRC_URI = "file://init.sh"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -dm 0755 ${D}/etc
- touch ${D}/etc/initrd-release
- install -dm 0755 ${D}/dev
- install -dm 0755 ${D}/sbin
- install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init
-}
-
-inherit allarch
-
-FILES_${PN} += " /dev /etc/initrd-release /sbin/init "
-
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
deleted file mode 100644
index 674c379..0000000
--- a/meta-sota/recipes-sota/ostree/ostree_git.bb
+++ /dev/null
@@ -1,83 +0,0 @@
-SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
-
-inherit autotools-brokensep pkgconfig systemd gobject-introspection
-
-INHERIT_remove_class-native = "systemd"
-
-SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
-
-SRCREV="3b09620c2738bce4ed45e099cf2e4c5df7671d39"
-
-PV = "2017.3-31-g3b09620c"
-
-S = "${WORKDIR}/git"
-
-BBCLASSEXTEND = "native"
-
-DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd gtk-doc-native"
-DEPENDS_remove_class-native = "systemd-native"
-
-RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz bash"
-RDEPENDS_${PN}_remove_class-native = "python-native"
-
-EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig"
-EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
-
-# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
-# do_configure stage so we do depend on it
-SYSROOT_DIR = "${STAGING_DIR_TARGET}"
-SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
-do_configure[vardeps] += "SYSROOT_DIR"
-
-SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
-SYSTEMD_REQUIRED_class-native = ""
-
-SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
-SYSTEMD_SERVICE_${PN}_class-native = ""
-
-PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
-PACKAGECONFIG_class-native = ""
-PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
-
-FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
-
-export STAGING_INCDIR
-export STAGING_LIBDIR
-
-do_configure() {
- unset docdir
- NOCONFIGURE=1 ./autogen.sh
- oe_runconf
-}
-
-do_compile_prepend() {
- export BUILD_SYS="${BUILD_SYS}"
- export HOST_SYS="${HOST_SYS}"
-}
-
-export SYSTEMD_REQUIRED
-
-do_install_append() {
- if [ -n ${SYSTEMD_REQUIRED} ]; then
- install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
- install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
- fi
-}
-
-FILES_${PN} += " \
- ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
- ${@'${libdir}/dracut/modules.d/98ostree/module-setup.sh' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
- ${datadir}/gir-1.0 \
- ${datadir}/gir-1.0/OSTree-1.0.gir \
- ${libdir}/girepository-1.0 \
- ${libdir}/girepository-1.0/OSTree-1.0.typelib \
-"
-
-PACKAGES =+ "${PN}-switchroot"
-
-FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"
-RDEPENDS_${PN}-switchroot = ""
-DEPENDS_remove_class-native = "systemd-native"
-
diff --git a/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
deleted file mode 100644
index 1fe2331..0000000
--- a/meta-sota/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ /dev/null
@@ -1,201 +0,0 @@
-DESCRIPTION = "sota-client rust recipe"
-HOMEPAGE = "https://github.com/advancedtelematic/rvi_sota_client"
-
-LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
-
-inherit cargo systemd
-
-S = "${WORKDIR}/git"
-
-# When changing this, don't forget to:
-# 1) Update PV
-# 2) Check that Cargo.lock hasn't changed with git diff old..new Cargo.lock
-SRCREV = "878aa386e61bc253e4fae624ae62507710cd23f3"
-
-# Generate with:
-# git describe --tags | cut -b2-
-# or from the rvi_sota_client repo:
-# make package-version
-PV = "0.2.32-131-g878aa38"
-
-BBCLASSEXTEND = "native"
-
-FILES_${PN} = " \
- /lib64 \
- ${bindir}/canonical_json.py \
- ${bindir}/sota_client \
- ${bindir}/sota_sysinfo.sh \
- ${bindir}/system_info.sh \
- ${bindir}/sota_ostree.sh \
- ${bindir}/sota_prov.sh \
- ${sysconfdir}/sota_client.version \
- ${sysconfdir}/sota_certificates \
- /var/sota/sota_provisioning_credentials.p12 \
- /var/sota/sota_provisioning_url.env \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/sota_client_autoprovision.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/sota_client.service', '', d)} \
- "
-
-# list of dependencies can be generated from Cargo.lock by running
-# cat Cargo.lock | sed -e '1,/metadata/ d' Cargo.lock | awk '{print "crate://crates.io/"$2 "/" $3" \\"}'
-SRC_URI = " \
-crate://crates.io/aho-corasick/0.5.3 \
-crate://crates.io/aho-corasick/0.6.3 \
-crate://crates.io/base64/0.4.1 \
-crate://crates.io/bit-set/0.4.0 \
-crate://crates.io/bit-vec/0.4.3 \
-crate://crates.io/bitflags/0.7.0 \
-crate://crates.io/byteorder/1.0.0 \
-crate://crates.io/bytes/0.4.1 \
-crate://crates.io/cfg-if/0.1.0 \
-crate://crates.io/chan/0.1.19 \
-crate://crates.io/chan-signal/0.2.0 \
-crate://crates.io/chrono/0.3.0 \
-crate://crates.io/crossbeam/0.2.10 \
-crate://crates.io/dbus/0.5.2 \
-crate://crates.io/deque/0.3.1 \
-crate://crates.io/dtoa/0.4.1 \
-crate://crates.io/env_logger/0.4.2 \
-crate://crates.io/error-chain/0.7.2 \
-crate://crates.io/foreign-types/0.2.0 \
-crate://crates.io/gcc/0.3.45 \
-crate://crates.io/gdi32-sys/0.2.0 \
-crate://crates.io/getopts/0.2.14 \
-crate://crates.io/httparse/1.2.1 \
-crate://crates.io/hyper/0.10.5 \
-crate://crates.io/idna/0.1.0 \
-crate://crates.io/iovec/0.1.0 \
-crate://crates.io/itoa/0.3.1 \
-crate://crates.io/kernel32-sys/0.2.2 \
-crate://crates.io/language-tags/0.2.2 \
-crate://crates.io/lazy_static/0.2.5 \
-crate://crates.io/libc/0.2.21 \
-crate://crates.io/log/0.3.7 \
-crate://crates.io/matches/0.1.4 \
-crate://crates.io/memchr/0.1.11 \
-crate://crates.io/memchr/1.0.1 \
-crate://crates.io/metadeps/1.1.1 \
-crate://crates.io/mime/0.2.3 \
-crate://crates.io/nom/1.2.4 \
-crate://crates.io/num/0.1.37 \
-crate://crates.io/num-integer/0.1.33 \
-crate://crates.io/num-iter/0.1.33 \
-crate://crates.io/num-traits/0.1.37 \
-crate://crates.io/num_cpus/1.3.0 \
-crate://crates.io/openssl/0.9.10 \
-crate://crates.io/openssl-sys/0.9.10 \
-crate://crates.io/pem/0.2.0 \
-crate://crates.io/pkg-config/0.3.9 \
-crate://crates.io/quote/0.3.15 \
-crate://crates.io/rand/0.3.15 \
-crate://crates.io/rayon/0.6.0 \
-crate://crates.io/redox_syscall/0.1.17 \
-crate://crates.io/regex/0.1.80 \
-crate://crates.io/regex/0.2.1 \
-crate://crates.io/regex-syntax/0.3.9 \
-crate://crates.io/regex-syntax/0.4.0 \
-crate://crates.io/ring/0.7.1 \
-crate://crates.io/rust-crypto/0.2.36 \
-crate://crates.io/rustc-serialize/0.3.23 \
-crate://crates.io/rustc_version/0.1.7 \
-crate://crates.io/semver/0.1.20 \
-crate://crates.io/serde/0.9.11 \
-crate://crates.io/serde_codegen_internals/0.14.1 \
-crate://crates.io/serde_derive/0.9.11 \
-crate://crates.io/serde_json/0.9.9 \
-crate://crates.io/sha1/0.2.0 \
-crate://crates.io/syn/0.11.9 \
-crate://crates.io/synom/0.11.3 \
-crate://crates.io/thread-id/2.0.0 \
-crate://crates.io/thread-id/3.0.0 \
-crate://crates.io/thread_local/0.2.7 \
-crate://crates.io/thread_local/0.3.3 \
-crate://crates.io/time/0.1.36 \
-crate://crates.io/toml/0.2.1 \
-crate://crates.io/toml/0.3.1 \
-crate://crates.io/traitobject/0.1.0 \
-crate://crates.io/tungstenite/0.1.1 \
-crate://crates.io/typeable/0.1.2 \
-crate://crates.io/unicase/1.4.0 \
-crate://crates.io/unicode-bidi/0.2.5 \
-crate://crates.io/unicode-normalization/0.1.4 \
-crate://crates.io/unicode-xid/0.0.4 \
-crate://crates.io/unix_socket/0.5.0 \
-crate://crates.io/unreachable/0.1.1 \
-crate://crates.io/untrusted/0.3.2 \
-crate://crates.io/url/1.4.0 \
-crate://crates.io/user32-sys/0.2.0 \
-crate://crates.io/utf-8/0.7.0 \
-crate://crates.io/utf8-ranges/0.1.3 \
-crate://crates.io/utf8-ranges/1.0.0 \
-crate://crates.io/uuid/0.4.0 \
-crate://crates.io/void/1.0.2 \
-crate://crates.io/winapi/0.2.8 \
-crate://crates.io/winapi-build/0.1.1 \
-git://github.com/advancedtelematic/rvi_sota_client \
-"
-
-SRC_URI[index.md5sum] = "79f10f436dbf26737cc80445746f16b4"
-SRC_URI[index.sha256sum] = "86114b93f1f51aaf0aec3af0751d214b351f4ff9839ba031315c1b19dcbb1913"
-
-SYSTEMD_SERVICE_${PN} = "sota_client.service sota_client_autoprovision.service"
-
-DEPENDS += " openssl openssl-native dbus "
-RDEPENDS_${PN} = " libcrypto \
- libssl \
- dbus \
- bash \
- lshw \
- jq \
- curl \
- python \
- python-canonicaljson \
- python-json \
- "
-
-export SOTA_AUTOPROVISION_CREDENTIALS
-export SOTA_AUTOPROVISION_URL
-
-do_compile_prepend() {
- export SOTA_VERSION=$(make sota-version)
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 target/${TARGET_SYS}/release/sota_client ${D}${bindir}
- install -m 0755 ${S}/run/sota_sysinfo.sh ${D}${bindir}
- ln -fs ${bindir}/sota_sysinfo.sh ${D}${bindir}/system_info.sh # For compatibilty with old sota.toml files
- install -m 0755 ${S}/run/sota_ostree.sh ${D}${bindir}
- install -m 0755 ${S}/run/sota_prov.sh ${D}${bindir}
- install -m 0755 ${S}/run/canonical_json.py ${D}${bindir}
-
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}/${systemd_unitdir}/system
- if [ -n "$SOTA_AUTOPROVISION_CREDENTIALS" ]; then
- install -c ${S}/run/sota_client_uptane_auto.service ${D}${systemd_unitdir}/system/sota_client.service
- else
- install -c ${S}/run/sota_client_ostree.service ${D}${systemd_unitdir}/system/sota_client.service
- fi
- install -c ${S}/run/sota_client_autoprovision.service ${D}${systemd_unitdir}/system/sota_client_autoprovision.service
- fi
-
- install -d ${D}${sysconfdir}
- echo `git log -1 --pretty=format:%H` > ${D}${sysconfdir}/sota_client.version
- install -c ${S}/run/sota_certificates ${D}${sysconfdir}
- ln -fs /lib ${D}/lib64
-
- if [ -n "$SOTA_AUTOPROVISION_CREDENTIALS" ]; then
- EXPDATE=`openssl pkcs12 -in $SOTA_AUTOPROVISION_CREDENTIALS -password "pass:" -nodes 2>/dev/null | openssl x509 -noout -enddate | cut -f2 -d "="`
-
- if [ `date +%s` -ge `date -d "${EXPDATE}" +%s` ]; then
- bberror "Certificate ${SOTA_AUTOPROVISION_CREDENTIALS} has expired on ${EXPDATE}"
- fi
-
- install -d ${D}/var
- install -d ${D}/var/sota
- install -m 0655 $SOTA_AUTOPROVISION_CREDENTIALS ${D}/var/sota/sota_provisioning_credentials.p12
- echo "SOTA_GATEWAY_URI=$SOTA_AUTOPROVISION_URL" > ${D}/var/sota/sota_provisioning_url.env
- fi
-
-}
diff --git a/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb b/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
deleted file mode 100644
index 326ff20..0000000
--- a/meta-sota/recipes-sota/sota-tools/sota-tools_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Utility to push data to a server"
-LICENSE = "MPL-2.0"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
-
-S = "${WORKDIR}/git"
-
-SRC_URI = "gitsm://github.com/advancedtelematic/sota-tools.git;branch=master"
-SRCREV = "4d7f22f50ab43be5bee61ad3e96cd9db4ef3a372"
-
-inherit cmake
-
-DEPENDS = "boost glib-2.0 curl"
-
-BBCLASSEXTEND = "native"
-
-FILES_${PN} = "${bindir}/garage-push"
-
-EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF"
-
-do_install() {
- install -d ${D}/${bindir}
- install -m 755 garage-push ${D}/${bindir}
-}