summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-sota')
-rw-r--r--meta-sota/recipes-sota/ostree-initrd/files/init.sh2
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb9
2 files changed, 6 insertions, 5 deletions
diff --git a/meta-sota/recipes-sota/ostree-initrd/files/init.sh b/meta-sota/recipes-sota/ostree-initrd/files/init.sh
index 5aa99d6..806a7b1 100644
--- a/meta-sota/recipes-sota/ostree-initrd/files/init.sh
+++ b/meta-sota/recipes-sota/ostree-initrd/files/init.sh
@@ -35,7 +35,7 @@ get_ostree_sysroot() {
done
}
-export PATH=/sbin:/usr/sbin:/bin:/usr/bin
+export PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/lib/ostree
log_info "starting initrd script"
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
index b5675ab..c2aeb2f 100644
--- a/meta-sota/recipes-sota/ostree/ostree_git.bb
+++ b/meta-sota/recipes-sota/ostree/ostree_git.bb
@@ -8,7 +8,7 @@ INHERIT_remove_class-native = "systemd"
SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
-SRCREV="v2016.5"
+SRCREV="v2016.11"
S = "${WORKDIR}/git"
@@ -20,8 +20,9 @@ DEPENDS_remove_class-native = "systemd-native"
RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz"
RDEPENDS_${PN}_remove_class-native = "python-native"
-EXTRA_OECONF = "CFLAGS='-DDISABLE_OTMPFILE' --with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
-EXTRA_OEMAKE = "CFLAGS='-DDISABLE_OTMPFILE'"
+EXTRA_OECONF = "CFLAGS='-g' --with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
+EXTRA_OEMAKE = "CFLAGS='-g'"
+EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
SYSTEMD_REQUIRED_class-native = ""
@@ -68,7 +69,7 @@ FILES_${PN} += " \
PACKAGES =+ "${PN}-switchroot"
-FILES_${PN}-switchroot = "${sbindir}/ostree-prepare-root"
+FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"
RDEPENDS_${PN}-switchroot = ""
DEPENDS_remove_class-native = "systemd-native"