summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-support')
-rw-r--r--meta-sota/recipes-support/fuse/fuse_%.bbappend3
-rw-r--r--meta-sota/recipes-support/glib-networking/glib-networking_%.bbappend1
-rw-r--r--meta-sota/recipes-support/gpgme/gpgme_%.bbappend1
-rw-r--r--meta-sota/recipes-support/libgsystem/libgsystem_git.bb38
-rw-r--r--meta-sota/recipes-support/libsoup/libsoup-2.4_%.bbappend3
-rw-r--r--meta-sota/recipes-support/util-linux/util-linux_%.bbappend10
6 files changed, 56 insertions, 0 deletions
diff --git a/meta-sota/recipes-support/fuse/fuse_%.bbappend b/meta-sota/recipes-support/fuse/fuse_%.bbappend
new file mode 100644
index 0000000..4f23349
--- /dev/null
+++ b/meta-sota/recipes-support/fuse/fuse_%.bbappend
@@ -0,0 +1,3 @@
+BBCLASSEXTEND = "native"
+
+PACKAGES_append_class-native = "fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native"
diff --git a/meta-sota/recipes-support/glib-networking/glib-networking_%.bbappend b/meta-sota/recipes-support/glib-networking/glib-networking_%.bbappend
new file mode 100644
index 0000000..d3267ac
--- /dev/null
+++ b/meta-sota/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -0,0 +1 @@
+BBCLASSEXTEND = "native"
diff --git a/meta-sota/recipes-support/gpgme/gpgme_%.bbappend b/meta-sota/recipes-support/gpgme/gpgme_%.bbappend
new file mode 100644
index 0000000..d3267ac
--- /dev/null
+++ b/meta-sota/recipes-support/gpgme/gpgme_%.bbappend
@@ -0,0 +1 @@
+BBCLASSEXTEND = "native"
diff --git a/meta-sota/recipes-support/libgsystem/libgsystem_git.bb b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
new file mode 100644
index 0000000..4b1eb49
--- /dev/null
+++ b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "GIO-based library, targeted primarily for use by operating system components"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SRC_URI = "gitsm://github.com/GNOME/libgsystem.git"
+SRCREV="d606bec68ddfea78de4b03c3f3568afb71bdc1ce"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep
+
+DEPENDS += "attr glib-2.0 pkgconfig libcap"
+RDEPENDS_${PN} = "xz systemd"
+
+RDEPENDS_${PN}_remove_class-native = "systemd-native"
+
+BBCLASSEXTEND = "native"
+
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+do_configure() {
+ NOCONFIGURE=true ./autogen.sh
+ oe_runconf
+}
+
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
+FILES_${PN} += " \
+ ${datadir} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/GSystem-1.0.gir \
+ ${libdir}/girepository-1.0/ \
+ ${libdir}/girepository-1.0/GSystem-1.0.typelib \
+"
diff --git a/meta-sota/recipes-support/libsoup/libsoup-2.4_%.bbappend b/meta-sota/recipes-support/libsoup/libsoup-2.4_%.bbappend
new file mode 100644
index 0000000..ed24273
--- /dev/null
+++ b/meta-sota/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -0,0 +1,3 @@
+BBCLASSEXTEND = "native"
+
+DEPENDS_append_class-native = " glib-networking-native"
diff --git a/meta-sota/recipes-support/util-linux/util-linux_%.bbappend b/meta-sota/recipes-support/util-linux/util-linux_%.bbappend
new file mode 100644
index 0000000..bd3f686
--- /dev/null
+++ b/meta-sota/recipes-support/util-linux/util-linux_%.bbappend
@@ -0,0 +1,10 @@
+PACKAGES_append_class-native = "util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native \
+ util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native \
+ util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native \
+ util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid \
+ util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native \
+ util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native \
+ util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock \
+ util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native \
+ ${@bb.utils.contains('PACKAGECONFIG', 'pylibmount', 'util-linux-pylibmount-native', '', d)}"
+