summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-08-27 14:41:02 -0400
committerScott Murray <scott.murray@konsulko.com>2024-08-28 15:53:45 +0000
commita4a7e630972444a7c3611df3de83b29d90814577 (patch)
treef8cbd152d407f03673da05d8af8bae2791e187a4
parent679611559e698e8078e9f74ce09a99d06b605891 (diff)
Fixes for latest meta-rcar-gen3 changesricefish_18.0.1ricefish/18.0.118.0.1ricefish
Updating to the bdab02fb commit of the scarthgap-dev branch in meta-renesas brought some breaking changes to meta-rcar-gen3 which we need to handle. Changes: - Updated arm-trusted-firmware bbappend to work against the significantly reworked upstream recipe. - Added gstreamer1.0-plugin-vspfilter-config bbappend to add in a conf file for the MACHINE=agl-ref-h3 scenario. - Updated branches in layer README for scarthgap, as that had been missed previously. Bug-AGL: SPEC-5239 Change-Id: I510f077ebde2bd6a01d0c486be3cabd356efe8f9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--README6
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend66
-rw-r--r--meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config/gstvspfilter-agl-refhw-h3_r8a7795.conf2
-rw-r--r--meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config_%.bbappend1
4 files changed, 31 insertions, 44 deletions
diff --git a/README b/README
index ed7bcd8..1f23cba 100644
--- a/README
+++ b/README
@@ -9,14 +9,14 @@ This layer depends on:
URI: git://git.openembedded.org/openembedded-core
layers: meta
- branch: kirkstone
+ branch: scarthgap
URI: git://git.openembedded.org/meta-openembedded
layers: meta-oe, meta-python
- branch: kirkstone
+ branch: scarthgap
URI: https://github.com/renesas-rcar/meta-renesas
- branch: kirkstone-dev_3.5_M3_v5.9.0
+ branch: scarthgap-dev
Build Instructions
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
index 4253d4f..84a0694 100644
--- a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
@@ -2,15 +2,20 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI:append:rcar-gen3 = " file://0001-rcar_gen3-plat-Do-not-panic-on-unrecognized-boards.patch"
-# It is believed the eMMC configuration below makes the result AGL
-# reference hardware specific, mark it as such when building with
+# Since it is believed the eMMC configuration below makes the result
+# AGL reference hardware specific, mark it as such when building with
# MACHINE=agl-refhw-h3 to potentially flag this in an incorrectly
# configured build.
COMPATIBLE_MACHINE:agl-refhw-h3 = "agl-refhw-h3"
# There are hardware issues in using hyperflash. arm-trusted-firmware, optee and
-# u-boot have to be stored into eMMC by using serial donwload.
-EMMC_BOOT_OPTION = "RCAR_SA6_TYPE=1"
+# u-boot have to be stored into eMMC by using serial download.
+# We need to specify it explicitly for the reference hardware configs when
+# building with MACHINE=h3ulcb to not break the h3ulcb builds.
+REFHW_ATFW_OPT_BOOTMODE = "RCAR_SA6_TYPE=1"
+
+# Use the existing bootmode flag with MACHINE=agl-refhw-h3
+USE_EMMC_BOOTMODE:agl-refh-h3 = "1"
# RCAR_DRAM_MEMRANK must be set, since in case of RCAR_DRAM_LPDDR4_MEMCONF=1
# ddr_rank_judge is called. But for RCAR_DRAM_MEMRANK=0 it can determine values
@@ -28,56 +33,35 @@ DDR_8G_OPTION = "RCAR_DRAM_LPDDR4_MEMCONF=1 RCAR_DRAM_MEMRANK=2"
# and please flash the firmware built with the following options.
DDR_8G_1RANK_OPTION = "RCAR_DRAM_LPDDR4_MEMCONF=1 RCAR_DRAM_MEMRANK=1"
-ATFW_OPT:agl-refhw-h3 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
-
#
-# Handle building as extra firmware with MACHINE=h3ulcb
+# Build configurations for MACHINE=agl-refhw-h3, derived from salvator_x_r8a7795
#
-# Build options for building as extra firmware when MACHINE=h3ulcb, based on H3[4x2g]
-H3ULCB[agl-refhw-4x2g] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
-H3ULCB[agl-refhw-4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_1RANK_OPTION}"
+agl_refhw_h3_r8a7795[4x2g] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${ATFW_OPT_LOSSY} ${ATFW_OPT_BOOTMODE} ${DDR_8G_OPTION}"
+agl_refhw_h3_r8a7795[4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${ATFW_OPT_LOSSY} ${ATFW_OPT_BOOTMODE} ${DDR_8G_1RANK_OPTION}"
-python __anonymous() {
- # If building for MACHINE=agl-refhw-h3, the predefined default
- # extra configurations in the base recipe are not interesting
- # to us, as there is no compatible hardware.
- if d.getVar("MACHINE") == "agl-refhw-h3":
- d.delVarFlag("H3", "2x2g")
- d.delVarFlag("H3", "4x2g")
-}
+#
+# Extra configurations for building as extra firmware with MACHINE=h3ulcb
+#
-# Also build the extra 1rank firmware when MACHINE=agl-refhw-h3
-H3[4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_1RANK_OPTION}"
+h3ulcb_r8a7795[agl-refhw-4x2g] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${ATFW_OPT_LOSSY} ${REFHW_ATFW_OPT_BOOTMODE} ${DDR_8G_OPTION}"
+h3ulcb_r8a7795[agl-refhw-4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${ATFW_OPT_LOSSY} ${REFHW_ATFW_OPT_BOOTMODE} ${DDR_8G_1RANK_OPTION}"
# Boot Normal World in EL2: this define configures ATF (SPSR register) to boot
# BL33 in EL2.
EXTRA_OEMAKE += " RCAR_BL33_EXECUTION_EL=1"
-#
-# Need to prepend the compile tasks with a distclean that actually cleans
-# out all the platform specific files like the new rcar_layout_tool output,
-# otherwise they do not get rebuilt and board builds can get the wrong
-# version of e.g. cert_headers_sa6. This needs to be addressed with
-# upstream.
-#
-
-do_compile:prepend() {
- oe_runmake distclean PLAT=${PLATFORM} MBEDTLS_COMMON_MK=1 ${ATFW_OPT}
-}
-
-do_ipl_opt_compile:prepend() {
- oe_runmake distclean PLAT=${PLATFORM} MBEDTLS_COMMON_MK=1 ${ATFW_OPT}
-}
+# Hook to rename firmware files when building with MACHINE=h3ulcb
+# to hopefully avoid confusion.
-do_extra_ipl_opt_refhw_fixup() {
+do_refhw_fixup() {
# Rename agl-refhw-h3 firmware files to drop h3ulcb-
- for f in ${DEPLOYDIR}/*-h3ulcb-agl-refhw-4x2g*; do
+ for f in ${S}/release/*-h3ulcb-agl-refhw-4x2g*; do
n=`basename $f | sed 's/h3ulcb-//'`
- mv -f $f ${DEPLOYDIR}/$n
+ mv -f $f ${S}/release/$n
done
}
-EXTRA_IPL_OPT_POSTFUNCS = ""
-EXTRA_IPL_OPT_POSTFUNCS_h3ulcb = "do_extra_ipl_opt_refhw_fixup"
-do_extra_ipl_opt[postfuncs] += "${EXTRA_IPL_OPT_POSTFUNCS}"
+DO_COMPILE_POSTFUNCS = ""
+DO_COMPILE_POSTFUNCS:h3ulcb = "do_refhw_fixup"
+do_compile[postfuncs] += "${DO_COMPILE_POSTFUNCS}"
diff --git a/meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config/gstvspfilter-agl-refhw-h3_r8a7795.conf b/meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config/gstvspfilter-agl-refhw-h3_r8a7795.conf
new file mode 100644
index 0000000..586b13b
--- /dev/null
+++ b/meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config/gstvspfilter-agl-refhw-h3_r8a7795.conf
@@ -0,0 +1,2 @@
+input-device-name=/dev/video20
+output-device-name=/dev/video21
diff --git a/meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config_%.bbappend b/meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config_%.bbappend
new file mode 100644
index 0000000..9accc57
--- /dev/null
+++ b/meta-agl-refhw-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter-config_%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"