aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-11-04 18:08:49 -0500
committerScott Murray <scott.murray@konsulko.com>2020-11-04 18:14:23 -0500
commite1fb6fe4b011369164e0e83a5cf5f0b1f2b4cf23 (patch)
tree1852ab6b3a97670c8d59bc194fc08d639a9820e8
parentc7d132ad45ac9b0326b6d4bb8f629d757336ddaa (diff)
Add dw-hdmi CEC IRQ muting patch
Add patch with fix for dw-hdmi IRQ issues provided by Kato Kazuomi from Panasonic. This resolves the WARNING backtraces related to an unhandled IRQ on boot and reading HDMI EDID. Bug-AGL: SPEC-3658 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6103bbec094d63ccabcb1ec273b73d8a5c114a84
-rw-r--r--meta-agl-refhw-gen3/recipes-kernel/linux/files/0003-rcar3-dw-hdmi-cec-mute.patch25
-rw-r--r--meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-refhw-gen3/recipes-kernel/linux/files/0003-rcar3-dw-hdmi-cec-mute.patch b/meta-agl-refhw-gen3/recipes-kernel/linux/files/0003-rcar3-dw-hdmi-cec-mute.patch
new file mode 100644
index 0000000..b0663ca
--- /dev/null
+++ b/meta-agl-refhw-gen3/recipes-kernel/linux/files/0003-rcar3-dw-hdmi-cec-mute.patch
@@ -0,0 +1,25 @@
+Mute CEC IRQ in dw-hdmi driver init
+
+Add muting of the CEC interrupt to initialize_hdmi_rcar_ih_mutes,
+which it previously did not have, unlike the original generic
+initialize_hdmi_ih_mutes function.
+
+Author: Kato Kazuomi (加藤 一臣) <kato.kazuomi@jp.panasonic.com>
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+---
+ drivers/gpu/drm/bridge/synopsys/dw-hdmi.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/gpu/drm/bridge/synopsys/dw-hdmi.c b/drivers/gpu/drm/bridge/synopsys/dw-hdmi.c
+index cedae37e6d28..b4a29d3954ae 100644
+--- a/drivers/gpu/drm/bridge/synopsys/dw-hdmi.c
++++ b/drivers/gpu/drm/bridge/synopsys/dw-hdmi.c
+@@ -1906,6 +1906,7 @@ static void initialize_hdmi_rcar_ih_mutes(struct dw_hdmi *hdmi)
+ hdmi_writeb(hdmi, 0x1f, HDMI_IH_MUTE_AS_STAT0);
+ hdmi_writeb(hdmi, 0x3f, HDMI_IH_MUTE_PHY_STAT0);
+ hdmi_writeb(hdmi, 0x03, HDMI_IH_MUTE_I2CM_STAT0);
++ hdmi_writeb(hdmi, 0x7f, HDMI_IH_MUTE_CEC_STAT0);
+ hdmi_writeb(hdmi, 0x0f, HDMI_IH_MUTE_VP_STAT0);
+ hdmi_writeb(hdmi, 0x03, HDMI_IH_MUTE_I2CMPHY_STAT0);
+
diff --git a/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
index a9cdd0c..c1fd753 100644
--- a/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -4,6 +4,7 @@ SRC_URI_append = " \
file://0001-create-r8a7795-usb-ovc-pinmux-groups.patch \
file://0001-add-agl-refhw.patch \
file://0002-add-st_asm330lhh-driver.patch \
+ file://0003-rcar3-dw-hdmi-cec-mute.patch \
file://refhw-rcar.cfg \
"